Интерактивная демонстрация


Результаты внедрения

Инструкции по установке обновлений

Инструкция по обновлению конфигурации «1С:УНФ 8. Полиграфия 2

Для обновления конфигурации следует использовать режим "Обновление конфигураций". Файл обновлений 1Cv8.cfu находится в каталоге шаблонов Armex\...... каталога шаблонов. (Как скачать обновление и установить в каталог шаблонов?)

1. Сделайте резервную копию вашей информационной базы.

2. Запустите 1С:Предприятие в режиме "Конфигуратор".

3. Откройте конфигурацию, для этого в меню "Конфигурация" выберите пункт "Открыть конфигурацию".

 

4. Вызовите режим "Обновление конфигураций", для этого в меню "Конфигурация", подменю "Поддержка", выберите пункт "Обновить конфигурацию".

 

5. В диалоге выбора обновления в качестве источника обновления укажите "Доступные обновления", после чего выберите нужное обновление в соответствующем списке.

 

 

 

6. Если в списке обновлений необходимое обновление отсутствует, то в диалоге выбора обновления в качестве источника обновления укажите "Файл обновления", после чего выберите нужный файл обновления (по умолчанию 1cv8.cfu).

7. В окне "Обновление конфигураций" нажмите кнопку "OK" для продолжения обновления конфигурации.

 

8. После завершения будет открыто окно "Конфигурация", содержащее конфигурацию с внесенными изменениями. Выполните сохранение конфигурации.

 

 

9. Запустите 1С:Предприятие в режиме "1С:Предприятие".

 

10. Текущая версия конфигурации предназначена для использования с обновленной версией системы лицензирования и защиты конфигурации 3.0………. Обновленные файлы защиты расположены в подкаталоге Protection (В подкаталоге ..\\Armex\ ….. каталога шаблонов)

 

В подкаталог Protection включены следующие установочные пакеты:

LicenceServer-{version}.Win.exe

  • Установочный пакет сервера СЛК и необходимых для его работы компонент
    (программа настройки параметров, программа управления службой).

  

LicenceAddIn-{version}-Win.exe

  • Установочный пакет внешней компоненты
    для установки/обновления компоненты без изменения макетов конфигураций.

UPKey-X.X.X.X-X.exe

  • Программа установки драйвера аппаратного ключа защиты.
    25B3.zip
  • архив с защищенными объектами конфигурации и лицензионными параметрами

Установка всех компонент производится в папку:

%ProgramFiles%>\1C\Licence\3.0

Создание резервной копии информационной базы

Резервную копию можно создать:

  • при использовании файлового варианта 1С:Предприятия 8 - путем копирования файла 1СV8.1CD в отдельный каталог;
  • при использовании клиент - серверного варианта 1С:Предприятия 8 - средствами SQL Server.

Независимо от используемого варианта 1С:Предприятия 8, резервную копию можно создать, используя режим выгрузки информационной базы. Для этого:

запустите систему 1С:Предприятие в режиме "Конфигуратор";

в меню "Администрирование" выберите пункт "Выгрузить информационную базу";

 

в открывшемся диалоге укажите имя файла, в который будут записаны данные.

 

Инструкция по обновлению модуля «Полиграфия 2» для 1C:ERP

Для успешной установки модуля необходимо выполнить следующие шаги:

Сделайте резервную копию вашей информационной базы.

1. Прежде всего, необходимо подготовить типовую конфигурацию. Включить возможность поддержки: «Конфигурация» – «Поддержка» – «Настройка поддержки».

 

 Правила поддержки устанавливаем так, как показано на рисунке.

 

 2. Далее необходимо установить режим редактирования «Объект поставщика редактируется с сохранением поддержки» для следующих объектов:

  • Корень конфигурации «Управление предприятием»;
  • Подсистемы-Администрирование-Настройка Разделов;
  • Общий модуль «Варианты отчетов УТПереопределяемый»;
  • Общий модуль «ДополнительныеОтчетыИОбработкиПереопределяемый»;
  • Общий модуль «УправлениеПечатьюУТСервер»;
  • Критерий отбора «Связанные документы»;
  • Подписки на события «Переопределить получаемую форму присоединенного файла»;
  • Функциональная опция «Использовать договоры с клиентами»;
  • Функциональная опция «Использовать партнеров и контрагентов»;
  • Функциональная опция «Использовать соглашения с клиентами»;
  • Определяемые типы «Владелец присоединенных файлов»;
  • Определяемые типы «Владелец присоединенных файлов объект»;
  • Определяемые типы «Владелец файлов»;
  • Определяемые типы «Присоединенный файл»;
  • Определяемые типы «Присоединенный файл объект»;
  • Общие команды «Структура Подчиненности»;
  • Справочник «Пользователи»;
  • Справочник «Номенклатура»;
  • Справочник «Наборы дополнительных реквизитов и сведений»;
  • Документ «Заказ клиента»;
  • Документ «Заказ поставщику»;
  • Документ «Заказ материалов в производство»;
  • Документ «Приобретение товаров и услуг»;
  • Документ «Производство без заказа»;
  • Планы видов характеристик «Дополнительные реквизиты и сведения»;
  • Бизнес-процессы «Задание».

3. Теперь запускаем сравнение конфигурации: «Конфигурация» – «Сравнить\Объединить» с конфигурацией из файла и выбираем файл поставки «1С:Полиграфия 2. Модуль для 1C:ERP».

4. Система обнаружит возможность объединения с постановкой на поддержку, на вопрос о постановке отвечаем «Да».

 

 5. В открытом окне сравнения\объединения снимаем все флажки.

6. Далее отмечаем объекты подсистемы «ПМЕ_Полиграфия», «слкСистемаЛицензированияОРСР» И «ПМЕ_СистемаЛицензированияПолиграфия»: «Действия» — «Отметить по подсистемам файла».

 

 7. Теперь находим в дереве сравнения объект критерий отбора «СвязанныеДокументы» и для свойства «Состав» ставим «Объединить».

 

 8. Далее в справочниках «Номенклатура», «Пользователи» и в документах «Заказ клиента», «Заказ материалов в производство» и «Производство без заказа» отмечаем для объединения из файла реквизиты с префиксом «ПМЕ».

 

 9. Отмечаем для объединения подсистемы с префиксом «ПМЕ».

10. Нажимаем кнопку «Выполнить», в окне поиска неразрешимых ссылок нажимаем «Продолжить».

11. Настройки правил поддержки оставляем по умолчанию, как показано на следующем рисунке.

 

 12. В модуле сеанса в процедуру «УстановкаПараметровСеанса» добавляем код:

//< слкСистемаЛицензированияОРСР
слкМенеджерЗащитыСервер.УстановкаПараметровСеанса(ТребуемыеПараметры);
// >слкСистемаЛицензированияОРС

Если в системе уже установлены модули для ERP других производителей, то, возможно, эта строка уже присутствует. Дублировать ее не надо.

13. Заходим в «Модуль управляемого приложения» в процедуре «ПриНачалеРаботыСистемы()» дописываем:

        // ++ Армекс 	
	ПМЕ_Общий.УстановкаПредопределенногоЗначенияХарактеристикиШиринаРоля();
	// -- Армекс

14. Вынесем подсистему «Полиграфия» перед «Производством» в списке: «Конфигурация» – «Свойства» – «Командный интерфейс». Передвигаем подсистему «Полиграфия» наверх до «Склад и доставка».

15. В модуле «ВариантыОтчетовУТПереопределяемый»

в процедуру «ОпределитьРазделыСВариантамиОтчетов» дописываем:

//++ Армекс
		Разделы.Добавить(Метаданные.Подсистемы.ПМЕ_Полиграфия,
			НСтр("ru= 'Отчеты по полиграфии'"));
		//-- Армекс
в процедуру «НастроитьВариантыОтчетов» дописываем:
#Область Армекс
	
		ОписаниеОтчета = ВариантыОтчетов.ОписаниеОтчета(Настройки, Метаданные.Отчеты.ПМЕ_АнализИзмененияСтатусовЗаказов);	
		ОписаниеВарианта = ВариантыОтчетов.ОписаниеВарианта(Настройки, ОписаниеОтчета, "АнализИзмененияСтатусовПолиграфическихЗаказов");
		ОписаниеВарианта.ВидимостьПоУмолчанию = Истина;
		ОписаниеВарианта.Описание = НСтр("ru= 'На какой стадии выполнения находится заказ?
		|Как долго заказ находился в определенном статусе.
		|Кто из пользователей является ответственным за изменения статуса у заказа?'");
		
		//Вариант = ВариантыОтчетов.ОписаниеВарианта(Настройки, Метаданные.Отчеты.ПМЕ_АнализИзмененияСтатусовЗаказов, "ПричиныПриостановки");
		//Вариант.Описание = НСтр("ru = 'Отчет отображает причины приостановки заказа.'");
		//Вариант.ВидимостьПоУмолчанию = Ложь;
		ОписаниеОтчета = ВариантыОтчетов.ОписаниеОтчета(Настройки, Метаданные.Отчеты.ПМЕ_ПричиныПриостановкиЗаказов);	
		ОписаниеВарианта = ВариантыОтчетов.ОписаниеВарианта(Настройки, ОписаниеОтчета, "ПричиныПриостановки");
		ОписаниеВарианта.ВидимостьПоУмолчанию = Истина;
		ОписаниеВарианта.Описание = НСтр("ru= 'Отчет отображает причины приостановки заказа.'");
		

		ОписаниеОтчета = ВариантыОтчетов.ОписаниеОтчета(Настройки, Метаданные.Отчеты.ПМЕ_Макеты);	
		ОписаниеВарианта = ВариантыОтчетов.ОписаниеВарианта(Настройки, ОписаниеОтчета, "Основной");
		ОписаниеВарианта.ВидимостьПоУмолчанию = Истина;
		ОписаниеВарианта.Описание = НСтр("ru= 'Сводная информация о клиенте, его заказах, дате заказа, полном имени (пути) файла макета за интервал дат.'");
		
		ОписаниеОтчета = ВариантыОтчетов.ОписаниеОтчета(Настройки, Метаданные.Отчеты.ПМЕ_НормированиеОпераций);	
		ОписаниеОтчета.ВидимостьПоУмолчанию = Истина;
		ОписаниеОтчета.Описание = НСтр("ru= 'Анализ введенных норм по стоимости, потерям, времени и нормам расхода материалов.'");
		
		Вариант = ВариантыОтчетов.ОписаниеВарианта(Настройки, Метаданные.Отчеты.ПМЕ_ВыработкаВырубныхШтампов, "");
		Вариант.Описание = НСтр("ru = 'Детальный анализ фактической выработки штампов постпрессовых операций полиграфических заказов.'");
		
		Вариант = ВариантыОтчетов.ОписаниеВарианта(Настройки, Метаданные.Отчеты.ПМЕ_ВыработкаОснастки, "");
		Вариант.Описание = НСтр("ru = 'Детальный анализ фактической выработки оснастки полиграфического оборудования по заказам.'");
		

		ОписаниеОтчета = ВариантыОтчетов.ОписаниеОтчета(Настройки, Метаданные.Отчеты.ПМЕ_НормированиеСкоростиОборудования);	
		ОписаниеОтчета.ВидимостьПоУмолчанию = Истина;
		//ОписаниеОтчета.Описание = НСтр("ru= 'Общие Сведения о введенных нормах по скорости работы печатного оборудования.'");
		ОписаниеОтчета.Описание = НСтр("ru = 'Общие Сведения о введенных нормах по скорости печатного оборудования.'");
		
		ОписаниеОтчета = ВариантыОтчетов.ОписаниеОтчета(Настройки, Метаданные.Отчеты.ПМЕ_ВыработкаФлексоформ);	
		ОписаниеОтчета.ВидимостьПоУмолчанию = Истина;
		ОписаниеОтчета.Описание = НСтр("ru= 'Детальный анализ фактической выработки флексоформ по заказам.'");
		
		ОписаниеОтчета = ВариантыОтчетов.ОписаниеОтчета(Настройки, Метаданные.Отчеты.ПМЕ_ВыработкаШтампов);	
		ОписаниеОтчета.ВидимостьПоУмолчанию = Истина;
		ОписаниеОтчета.Описание = НСтр("ru= 'Детальный анализ фактической выработки штампов (высекальных ножей) по флексозаказам.'");
		

		ОписаниеОтчета = ВариантыОтчетов.ОписаниеОтчета(Настройки, Метаданные.Отчеты.ПМЕ_ВыполнениеЗаказов);	
		ОписаниеВарианта = ВариантыОтчетов.ОписаниеВарианта(Настройки, ОписаниеОтчета, "ОтчетОВыполненииЗаказов");
		ОписаниеВарианта.ВидимостьПоУмолчанию = Истина;
		ОписаниеВарианта.Описание = НСтр("ru= 'Анализ движения заказов по журналу оператора.
		|Какая операция заказ сейчас выполняется?.
		|Общая длительность выполнения операций по заказу.'");
		
		ОписаниеОтчета = ВариантыОтчетов.ОписаниеОтчета(Настройки, Метаданные.Отчеты.ПМЕ_ЗаказыГотовыеКПланированиюДолгосрочноеПланирование);	
		ОписаниеВарианта = ВариантыОтчетов.ОписаниеВарианта(Настройки, ОписаниеОтчета, "ЗаказыКПланированию");
		ОписаниеВарианта.ВидимостьПоУмолчанию = Истина;
		ОписаниеВарианта.Описание = НСтр("ru= 'Данные о готовности заказов клиентов к планированию (документом План производства полиграфии).'");

		ОписаниеОтчета = ВариантыОтчетов.ОписаниеОтчета(Настройки, Метаданные.Отчеты.ПМЕ_ВыполнениеЗаказовДолгосрочноеПланирование);	
		ОписаниеВарианта = ВариантыОтчетов.ОписаниеВарианта(Настройки, ОписаниеОтчета, "ОтчетОВыполненииЗаказов");
		ОписаниеВарианта.ВидимостьПоУмолчанию = Истина;
		ОписаниеВарианта.Описание = НСтр("ru= 'Анализ выполнения заказов по введенным планам производства полиграфии.
		|Текущее состояние выполнения операций заказа.
		|Анализ выполнения операций заказа в разрезе исполнителей.'");
		
		ОписаниеОтчета = ВариантыОтчетов.ОписаниеОтчета(Настройки, Метаданные.Отчеты.ПМЕ_ВыполненныеЗаказыДолгосрочноеПланирование);	
		ОписаниеВарианта = ВариантыОтчетов.ОписаниеВарианта(Настройки, ОписаниеОтчета, "ВыполненныеЗаказы");
		ОписаниеВарианта.ВидимостьПоУмолчанию = Истина;
		ОписаниеВарианта.Описание = НСтр("ru= 'Анализ всех выполненных заказов по данным планам производства.'");

		ОписаниеОтчета = ВариантыОтчетов.ОписаниеОтчета(Настройки, Метаданные.Отчеты.ПМЕ_ВыработкаСотрудниковОперативноеПланирование);	
		ОписаниеВарианта = ВариантыОтчетов.ОписаниеВарианта(Настройки, ОписаниеОтчета, "ВыработкаСотрудников");
		ОписаниеВарианта.ВидимостьПоУмолчанию = Истина;
		ОписаниеВарианта.Описание = НСтр("ru= 'Сводная информация о выработке сотрудников производства в разрезе отработанных часов и общего количестве выполненных операций.'");
	
		
		ОписаниеОтчета = ВариантыОтчетов.ОписаниеОтчета(Настройки, Метаданные.Отчеты.ПМЕ_ДиаграммаВыполненияЗаказов);	
		ОписаниеОтчета.ВидимостьПоУмолчанию = Истина;
		ОписаниеОтчета.Описание = НСтр("ru= 'Просмотр и анализ выполнения заказов плана в виде диаграммы Ганта.
		|Возможна настройка анализа группировок по рабочим центрам или по операциям.'");
		
		ОписаниеОтчета = ВариантыОтчетов.ОписаниеОтчета(Настройки, Метаданные.Отчеты.ПМЕ_ДиаграммаЗагрузкиРабочихЦентровПолиграфии);	
		ОписаниеОтчета.ВидимостьПоУмолчанию = Истина;
		ОписаниеОтчета.Описание = НСтр("ru= 'Анализ плановой загрузки рабочих центров по заказам.'");
		
		ОписаниеОтчета = ВариантыОтчетов.ОписаниеОтчета(Настройки, Метаданные.Отчеты.ПМЕ_ДиаграммаЗагрузкиРабочихЦентровПолиграфииПланФакт);	
		ОписаниеОтчета.ВидимостьПоУмолчанию = Истина;
		ОписаниеОтчета.Описание = НСтр("ru= 'Сравнение плановых и фактических данных по загрузке рабочих центров за период.'");
		
		ОписаниеОтчета = ВариантыОтчетов.ОписаниеОтчета(Настройки, Метаданные.Отчеты.ПМЕ_ПланФактныйАнализПланированияПроизводства);	
		ОписаниеОтчета.ВидимостьПоУмолчанию = Истина;
		ОписаниеОтчета.Описание = НСтр("ru= 'План-фактный анализ выполнения заказов.
		|Каковы расхождения по времени выполнения и тиражу операций. 
		|Сравнение плановых и фактических показателей начала и выполнения операций.'");

		ОписаниеОтчета = ВариантыОтчетов.ОписаниеОтчета(Настройки, Метаданные.Отчеты.ПМЕ_СменноСуточноеЗаданиеПоПолиграфии);	
        ОписаниеОтчета.ВидимостьПоУмолчанию = Истина;
		ОписаниеОтчета.Описание = НСтр("ru= 'Формы бланков сменно-суточного задания для каждого рабочего центра.'");

		ОписаниеОтчета = ВариантыОтчетов.ОписаниеОтчета(Настройки, Метаданные.Отчеты.ПМЕ_ВыработкаОборудованияПоЗаказам);	
        ОписаниеОтчета.ВидимостьПоУмолчанию = Истина;
		ОписаниеОтчета.Описание = НСтр("ru= 'Сводная информация об остатке нормативов по обслуживанию оборудования за выбранный интервал дат.'");

		ОписаниеОтчета = ВариантыОтчетов.ОписаниеВарианта(Настройки, Метаданные.Отчеты.ПМЕ_РасширенныйАнализСебестоимостиВыпускаПолиграфии, "" );	
		ОписаниеОтчета.ВидимостьПоУмолчанию = Истина;
		ОписаниеОтчета.Описание = НСтр("ru= 'Соотношение фактического и планируемого количества и себестоимости затрат на выпуск продукции.
		|Сравнение плановых и фактических показателей прибыли по заказам, оценка фактической рентабельность заказа.'");

		Вариант = ВариантыОтчетов.ОписаниеВарианта(Настройки, Метаданные.Отчеты.ПМЕ_АнализКалькуляционнойИСогласованнойСтоимостиЗаказа, "");	
		Вариант.Описание = НСтр("ru= 'Сравнение калькуляционной и согласованной стоимости заказа.'");

		Вариант = ВариантыОтчетов.ОписаниеВарианта(Настройки, Метаданные.Отчеты.ПМЕ_ПростоиОборудования, "ПростоиОборудования");	
		Вариант.Описание = НСтр("ru= 'Анализа данных о времени и причинах простоя полиграфического оборудования.'");
		
		Вариант = ВариантыОтчетов.ОписаниеВарианта(Настройки, Метаданные.Отчеты.ПМЕ_ЗадержкаВремениВыполненияОперацийМеждуРабочимиЦентрами, "ЗадержкаВремениВыполненияОперацийМеждуРабочимиЦентрами");	
		Вариант.Описание = НСтр("ru= 'Анализ временных задержек при передаче выполнении операции между разными рабочими центрами.'");

   #КонецОбласти

16. В модуле «ДополнительныеОтчетыИОбработкиПереопределяемый»

в процедуру «ОпределитьРазделыСДополнительнымиОбработками» дописываем:

		//++ Армекс
		ОбщегоНазначенияУТ.ДобавитьПодсистемуВКоллекцию(Разделы, "ПМЕ_Полиграфия");
		//-- Армекс

17. В модуле «УправлениеПечатьюУТСервер»

в процедуру «ОпределитьОбъектыСКомандамиПечати» дописываем:

//Армекс
	СписокОбъектов.Добавить(Справочники.ПМЕ_ТехКартаФлексопечать);
	СписокОбъектов.Добавить(Документы.ПМЕ_ЗаказПокупателя);
	СписокОбъектов.Добавить(Документы.ПМЕ_КомпоновкаЗаказов);
	СписокОбъектов.Добавить(Документы.ПМЕ_РасчетЗаказа);
	СписокОбъектов.Добавить(Документы.ПМЕ_РасчетСоставляющей);
	СписокОбъектов.Добавить(Документы.ПМЕ_РасчетФлексопечати);
	СписокОбъектов.Добавить(Документы.ПМЕ_СложныйЗаказ);

	//Армекс

18. Заходим в свойства критерия отбора «СвязанныеДокументы»

  • дополнительно отмечаем типы «ПМЕ_СложныйЗаказ», «ПМЕ_ЗаказПокупателя», «ПМЕ_РасчетФлексопечати», «ПМЕ_РасчетЗаказа», «ПМЕ_КомпоновкаЗаказов»;
  • в состав добавляем реквизит «ПМЕ_ДокументОснование» документа «ЗаказКлиента».

19. Заходим в подписки на события «ПереопределитьПолучаемуюФормуПрисоединенногоФайла» дополнительно отмечаем в источнике тип «СправочникМенеджер.ПМЕ_СхемыКПолиграфическимОперациямПрисоединенныеФайлы» и «СправочникМенеджер.ПМЕ_ШаблоныПечатиОфисныхДокументовПрисоединенныеФайлы».

20. Заходим в функциональную опцию «Использовать договоры с клиентами» и в состав добавляем ссылку на реквизит «Договор» документов: «ПМЕ_ЗаказПокупателя», «ПМЕ_РасчетЗаказа», «ПМЕ_РасчетЗаказаШаблон», «ПМЕ_РасчетФлексопечати», «ПМЕ_РасчетФлексопечатиШаблон», «ПМЕ_СложныйЗаказ», «ПМЕ_СложныйЗаказШаблон».

21. Заходим в функциональную опцию «Использовать партнеров и контрагентов» и в состав добавляем ссылку на реквизит «Контрагент» документов: «ПМЕ_ЗаказПокупателя», «ПМЕ_РасчетЗаказа», «ПМЕ_РасчетЗаказаШаблон», «ПМЕ_РасчетФлексопечати», «ПМЕ_РасчетФлексопечатиШаблон», «ПМЕ_СложныйЗаказ», «ПМЕ_СложныйЗаказШаблон».

22. Заходим в функциональную опцию «Использовать соглашения с клиентами» и в состав добавляем ссылку на реквизит «Соглашение» документов: «ПМЕ_ЗаказПокупателя», «ПМЕ_РасчетЗаказа», «ПМЕ_РасчетЗаказаШаблон», «ПМЕ_РасчетФлексопечати», «ПМЕ_РасчетФлексопечатиШаблон», «ПМЕ_СложныйЗаказ», «ПМЕ_СложныйЗаказШаблон».

23. Заходим в определяемый тип «Владелец присоединенных файлов» в свойстве «Тип» добавляем ссылку на объекты:

                          -->СправочникСсылка.ПМЕ_БиблиотекаШтампов
			- -->ДокументСсылка.ПМЕ_СложныйЗаказ
			- -->ДокументСсылка.ПМЕ_РасчетФлексопечати
			- -->ДокументСсылка.ПМЕ_РасчетЗаказа
			- -->СправочникСсылка.ПМЕ_СхемыКПолиграфическимОперациям
			- -->СправочникСсылка.ПМЕ_ВырубныеШтампы
			- -->СправочникСсылка.ПМЕ_ШаблоныПечатиОфисныхДокументо.

24.Заходим в определяемый тип «ВладелецПрисоединенныхФайловОбъект» в свойстве «Тип» добавляем ссылку на объекты:

                        - -->СправочникОбъект.ПМЕ_ШаблоныПечатиОфисныхДокументов
			- -->СправочникОбъект.ПМЕ_СхемыКПолиграфическимОперациям

25. Заходим в определяемый тип «ВладелецФайлов» и в свойстве «Тип» добавляем ссылку на справочник «ПМЕ_БиблиотекаШтампов», справочник «ПМЕ_ВырубныеШтампы» и на документы: «ПМЕ_СложныйЗаказ», «ПМЕ_РасчетФлексопечати», «ПМЕ_РасчетЗаказа».

26. Заходим в определяемый тип «ПрисоединенныйФайл», «ПрисоединенныйФайлОбъект» и в свойстве «Тип» добавляем ссылку на справочники: «ПМЕ_СхемыКПолиграфическимОперациямПрисоединенныеФайлы» и «ПМЕ_ШаблоныПечатиОфисныхДокументовПрисоединенныеФайлы».

27. Заходим в общую команду «СтруктураПодчиненности» в свойстве «Тип параметра команды» добавляем ссылку на документы: «ПМЕ_ЗаказПокупателя», «ПМЕ_КомпоновкаЗаказов», «ПМЕ_СложныйЗаказ», «ПМЕ_РасчетФлексопечати», «ПМЕ_РасчетЗаказа».

28. Заходим в справочник «Номенклатура»  

  • в свойстве «Предопределенные» добавляем две папки: «Краска» и «Пленка».
  • на Форму элемента на закладку «Реквизиты» добавляем сворачиваемую группу «Полиграфические параметры» ( ниже группы «Сворачиваемая группа единицы измерения»)  реквизитами и табличной частью, имеющими  префикс «ПМЕ».

 

  • на Форме элемента вносим изменения в функцию «ИменаСворачиваемыхГрупп()»;
    	// Армекс--->
    	ИменаСворачиваемыхГрупп.Добавить("Полиграфия");
    	// 
    
  • на Форме элемента вносим изменения в процедуру «ЗаполнитьПоПараметрам»; заменяем код
    ЗаполнитьЗначенияСвойств(Объект, ИсточникКопирования, , "ГруппаДоступа, ФайлКартинки, ФайлОписанияДляСайта, 
    		    |ДополнительныеРеквизиты, ДрагоценныеМатериалы, Код, ПометкаУдаления ");
    на	
    ЗаполнитьЗначенияСвойств(Объект, ИсточникКопирования, , "ГруппаДоступа, ФайлКартинки, ФайлОписанияДляСайта, 
    		    |ДополнительныеРеквизиты, ДрагоценныеМатериалы, Код, ПометкаУдаления, ПМЕ_Материалы");
    
    
  • на Форме элемента вносим изменения в процедуру «ПриСозданииНаСервере»;
    // +++ Армекс
    ПМЕ_ВидимостьПолиграфическихПараметров();
    // --- Армекс
    
    
  • на Форму элемента добавляем все процедуры области Армекс.
    #Область Армекс
    &НаСервере
    Процедура ПМЕ_ЗаполнитьПлотностьНаСервере()
    	Выборка = Справочники.ПМЕ_Плотность.Выбрать();	
    	Пока   Выборка.Следующий() Цикл
    		Если  Выборка.ЭтоГруппа = Ложь Тогда
    			НоваяСтрока =Объект.ПМЕ_Материалы.Добавить();
    			НоваяСтрока.Плотность=   Выборка.Ссылка;
    		КонецЕсли;
    	КонецЦикла; 
    
    КонецПроцедуры
    
    &НаКлиенте
    Процедура ПМЕ_ЗаполнитьПлотность(Команда)
    	Если Объект.ПМЕ_Материалы.Количество()>0 Тогда
    		Режим = РежимДиалогаВопрос.ДаНет;
    		
    		ТекстВопроса = НСтр("ru = 'Таблица будет очищена!
    		|Продолжить?'");
    		
    		Оповещение = Новый ОписаниеОповещения("ОчисткаТаблицыМатериалы", ЭтотОбъект);
    		ПоказатьВопрос(Оповещение, ТекстВопроса, Режим,0);
    		
    	КонецЕсли;
    	ПМЕ_ЗаполнитьПлотностьНаСервере();
    КонецПроцедуры
    
    &НаКлиенте
     Процедура ОчисткаТаблицыМатериалы(Результат, Параметры) Экспорт
    	 Если Результат = КодВозвратаДиалога.Да Тогда
    		 Объект.ПМЕ_Материалы.Очистить();
    		 
    	 КонецЕсли;
     КонецПроцедуры
     &НаСервере
    Процедура ПМЕ_ВидимостьПолиграфическихПараметров()
    
    	// Армекс---->
    	Если ЗначениеЗаполнено(Объект.Родитель) Тогда
    		
    		ЗапросНаРодителяКраска = Новый Запрос;
    		ЗапросНаРодителяКраска.Текст = "ВЫБРАТЬ
    		                               |	ВЫБОР
    		                               |		КОГДА Номенклатура.Родитель В ИЕРАРХИИ (&РодительКраска)
    		                               |			ТОГДА ИСТИНА
    		                               |		ИНАЧЕ ЛОЖЬ
    		                               |	КОНЕЦ КАК ГруппаКраска
    		                               |ИЗ
    		                               |	Справочник.Номенклатура КАК Номенклатура
    		                               |ГДЕ
    		                               |	Номенклатура.Родитель = &ВыбРодитель";
    		ЗапросНаРодителяКраска.УстановитьПараметр("РодительКраска",Справочники.Номенклатура.Краска);
    		ЗапросНаРодителяКраска.УстановитьПараметр("ВыбРодитель",Объект.Родитель);
    		ВыборкаПоРодителюКраска = ЗапросНаРодителяКраска.Выполнить().Выбрать();
    		
    		Если ВыборкаПоРодителюКраска.Следующий() Тогда
    			Элементы.ГруппаПараметрыКраски.Видимость = ВыборкаПоРодителюКраска.ГруппаКраска;
    			Если Константы.ПМЕ_ИспользоватьВозможностьУказыватьВКраскеПроцентСухогоОстатка.Получить() тогда
    				Элементы.ПМЕ_ПроцентСухогоОстатка.Видимость = истина;
    			иначе
    				Элементы.ПМЕ_ПроцентСухогоОстатка.Видимость = Ложь;
    			КонецЕсли;
    		Иначе
    			Элементы.ГруппаПараметрыКраски.Видимость = Ложь;		
    		КонецЕсли; 	
    	Иначе
    		
    		Элементы.ГруппаПараметрыКраски.Видимость = Ложь;	
    	КонецЕсли;
    КонецПроцедуры
    
    &НаКлиенте
    Процедура РодительПриИзменении(Элемент)
    	 ПМЕ_ВидимостьПолиграфическихПараметров();
    
    КонецПроцедуры
    
    #КонецОбласти
    
    
  • На форме реквизиту «Родитель» добавить в событии «ПриИзменении» ссылку на процедуру «РодительПриИзменении»

29. Заходим в справочник «Пользователи» на форму элемента добавляем реквизит «ПМЕ_РольПользователя».

30. Заходим в справочник «Наборы дополнительных реквизитов и сведений»

  • в свойстве «Предопределенные» добавляем папку «ПМЕ_ПолиграфическиеОбъекты» и все ее содержимое (Документ_ПМЕ_РасчетЗаказа, Документ_ПМЕ_СложныйЗаказ, Документ_ПМЕ_РасчетФлексопечати, Документ_ПМЕ_ЗаказПокупателя, Документ_ПМЕ_КомпоновкаЗаказов).

31. Заходим в документ «ЗаказКлиента»

  • на форму документа добавляем реквизит «ПМЕ_ДокументОснование»;
  • на форме документа вносим изменения в процедуру «ПослеЗаписи» ( текст вносим после строчки с кодом Оповестить("Запись_ЗаказКлиента", ПараметрыЗаписи, Объект.Ссылка));
    // Армекс ----->
    	// Если открыли данную форму из формы документа, то там надо поменять текст.
    	Попытка
    		Если ВладелецФормы <> Неопределено Тогда
    			
    			ВладелецФормы.АвтоТест_ЗаполнитьТекстЗаказПокупателя();
    		КонецЕсли;
    		
    	Исключение 
    	КонецПопытки;
    	
    	// 
    
  • на форму документа добавляем все процедуры области Армекс.
     #Область Армекс
    &НаКлиенте
    Процедура ПМЕ_ДокументОснованиеПриИзменении(Элемент)
    	Попытка
    		Если ЗначениеЗаполнено(Объект.ПМЕ_ДокументОснование)  Тогда
    			Режим = РежимДиалогаВопрос.ДаНет;
    			
    			ТекстВопроса = НСтр("ru = 'Перезаполнить табличные части заказ покупателя данными из расчета?'");
    			
    			Оповещение = Новый ОписаниеОповещения("ПослеЗакрытияВопроса", ЭтотОбъект);
    			ПоказатьВопрос(Оповещение, ТекстВопроса, Режим,0);
    		КонецЕсли;
    	Исключение
    		
    	КонецПопытки;
    	
    	КонецПроцедуры
    &НаКлиенте
    Процедура ПослеЗакрытияВопроса(Результат, Параметры) Экспорт
    	Если Результат = КодВозвратаДиалога.Да Тогда
    		ЗаполнитьПоРасчетЗаказу();
    	КонецЕсли;
    КонецПроцедуры
    
    &НаСервере
    Процедура ЗаполнитьПоРасчетЗаказу() Экспорт
    	//Получим контекст формы
    	ЗаполнитьЗначенияСвойств(Объект,Объект.ПМЕ_ДокументОснование);
    	Объект.Менеджер                    =  Объект.ПМЕ_ДокументОснование.Ответственный;
    	Если ТипЗнч(Объект.ПМЕ_ДокументОснование) = Тип("ДокументСсылка.ПМЕ_КомпоновкаЗаказов") Тогда
    		Объект.ДатаОтгрузки        = Объект.ПМЕ_ДокументОснование.Работа_ДатаОкончания;
    	ИначеЕсли ТипЗнч(Объект.ПМЕ_ДокументОснование) = Тип("ДокументСсылка.ПМЕ_РасчетЗаказа") ИЛИ ТипЗнч(Объект.ПМЕ_ДокументОснование) = Тип("ДокументСсылка.ПМЕ_РасчетФлексопечати") или ТипЗнч(Объект.ПМЕ_ДокументОснование) = Тип("ДокументСсылка.ПМЕ_СложныйЗаказ")  Тогда		
    		Объект.ДатаОтгрузки        = Объект.ПМЕ_ДокументОснование.ДатаВып;
    	КонецЕсли;
    	Объект.Товары.Очистить();
    	
    	Если ТипЗнч(Объект.ПМЕ_ДокументОснование) = Тип("ДокументСсылка.ПМЕ_РасчетЗаказа")  или ТипЗнч(Объект.ПМЕ_ДокументОснование) = Тип("ДокументСсылка.ПМЕ_СложныйЗаказ")  Тогда
    		Строка= Объект.Товары.Добавить();
    		Строка.Номенклатура         = Объект.ПМЕ_ДокументОснование.Продукция;
    		Строка.Характеристика         = Объект.ПМЕ_ДокументОснование.ХарактеристикаПродукции;
    		Строка.Количество        = Объект.ПМЕ_ДокументОснование.Тираж;
    		Строка.КоличествоУпаковок           = Объект.ПМЕ_ДокументОснование.Тираж;
    		Строка.ВидЦены         =    Объект.ПМЕ_ДокументОснование.ВидЦены;	
    		Строка.ВариантОбеспечения  =   Перечисления.ВариантыОбеспечения.Требуется;			
    		Строка.Сумма                = Объект.ПМЕ_ДокументОснование.СуммаСоСкидкой;			
    		Строка.СтавкаНДС            = Объект.ПМЕ_ДокументОснование.СтавкаНДС;
    		Строка.ДатаОтгрузки        = Объект.ДатаОтгрузки;
    		Если Строка.КоличествоУпаковок <>0 Тогда
    			Строка.Цена = Окр((Строка.Сумма ) /Строка.КоличествоУпаковок, 2);
    		иначе
    			Строка.Цена = 0;
    			
    		КонецЕсли;
    	ИначеЕсли ТипЗнч(Объект.ПМЕ_ДокументОснование) = Тип("ДокументСсылка.ПМЕ_РасчетФлексопечати") Тогда
    		ТЗНоменклатураЗаказа= Объект.ПМЕ_ДокументОснование.НоменклатураЗаказа.Выгрузить();
    		ТЗНоменклатураЗаказа.Свернуть("Продукция,Характеристика,Формат","Тираж");
    		Для Каждого стрр из ТЗНоменклатураЗаказа цикл
    			Строка= Объект.Товары.Добавить();
    			Строка.Номенклатура         = стрр.Продукция;
    			Строка.Характеристика         = стрр.Характеристика;
    			Если   Объект.ПМЕ_ДокументОснование.ЦенаВЗаказе  =0 тогда
    				Строка.Количество           = стрр.Тираж;
    			Иначе
    				Строка.Количество           = стрр.Тираж*0.001;
    			КонецЕсли;
    			//Строка.Количество        = стрр.Тираж;
    			Строка.КоличествоУпаковок           = Строка.Количество;
    			Строка.ВидЦены         =    Объект.ПМЕ_ДокументОснование.ВидЦены;	
    			Строка.ВариантОбеспечения  =   Перечисления.ВариантыОбеспечения.Требуется;			
    			Если Объект.ПМЕ_ДокументОснование.ЕдиницаИзмеренияТиража =2 тогда
    				Строка.Сумма                = ?(Объект.ПМЕ_ДокументОснование.НоменклатураЗаказа.Итог("Тираж") =0,0,Объект.ПМЕ_ДокументОснование.СуммаСоСкидкой*стрр.Тираж/Объект.ПМЕ_ДокументОснование.НоменклатураЗаказа.Итог("Тираж"));		
    			Иначе
    				Строка.Сумма                = ?(Объект.ПМЕ_ДокументОснование.Тираж =0,0,Объект.ПМЕ_ДокументОснование.СуммаСоСкидкой*стрр.Тираж/Объект.ПМЕ_ДокументОснование.Тираж);
    			КонецЕсли;
    			Строка.СтавкаНДС            = Объект.ПМЕ_ДокументОснование.СтавкаНДС;
    			Строка.ДатаОтгрузки        = Объект.ДатаОтгрузки;
    			Если Строка.КоличествоУпаковок <>0 Тогда
    				Строка.Цена = Окр((Строка.Сумма ) /Строка.КоличествоУпаковок, 2);
    			иначе
    				Строка.Цена = 0;
    				
    			КонецЕсли;
    		КонецЦикла;
    		
    	ИначеЕсли ТипЗнч(Объект.ПМЕ_ДокументОснование) = Тип("ДокументСсылка.ПМЕ_ЗаказПокупателя") Тогда
    		НоваяТаблицаРасчетыЗаказов =Объект.ПМЕ_ДокументОснование.РасчетыЗаказов.Выгрузить();
    		НоваяТаблицаРасчетыЗаказов.Свернуть("ДокументРасчета,Расчет_Продукция,ХарактеристикаПродукции","Расчет_Сумма,Расчет_Тираж"); 
    		Для Каждого СтрЗаказИзЗаявки Из НоваяТаблицаРасчетыЗаказов Цикл
    			Строка= Объект.Товары.Добавить();
    			Строка.Номенклатура         = СтрЗаказИзЗаявки.Расчет_Продукция;
    			Строка.Характеристика         = СтрЗаказИзЗаявки.ХарактеристикаПродукции;
    			Строка.Количество        = СтрЗаказИзЗаявки.Расчет_Тираж;
    			Строка.КоличествоУпаковок           = СтрЗаказИзЗаявки.Расчет_Тираж;
    			Строка.ВидЦены         =    Объект.ПМЕ_ДокументОснование.ВидЦены;	
    			Строка.ВариантОбеспечения  =   Перечисления.ВариантыОбеспечения.Требуется;			
    			Строка.Сумма                = СтрЗаказИзЗаявки.Расчет_Сумма;			
    			Строка.СтавкаНДС            = Объект.ПМЕ_ДокументОснование.СтавкаНДС;
    			Строка.ДатаОтгрузки        = Объект.ДатаОтгрузки;
    			Если Строка.КоличествоУпаковок <>0 Тогда
    				Строка.Цена = Окр((Строка.Сумма ) /Строка.КоличествоУпаковок, 2);
    			иначе
    				Строка.Цена = 0;
    				
    			КонецЕсли;
    		КонецЦикла;
    	ИначеЕсли ТипЗнч(Объект.ПМЕ_ДокументОснование) = Тип("ДокументСсылка.ПМЕ_КомпоновкаЗаказов") Тогда
    		
    		Для Каждого Стр Из Объект.ПМЕ_ДокументОснование.ИзделияКомпоновки Цикл
    			Строка= Объект.Товары.Добавить();
    			Строка.Номенклатура         = Стр.Изделие_Название;
    			Строка.Характеристика         = Стр.ХарактеристикаПродукции;
    			Строка.Количество        = Стр.Изделие_Тираж;
    			Строка.КоличествоУпаковок           = Стр.Изделие_Тираж;
    			Строка.ВидЦены         =    Объект.ПМЕ_ДокументОснование.ВидЦены;	
    			Строка.ВариантОбеспечения  =   Перечисления.ВариантыОбеспечения.Требуется;			
    			
    			Если ТипЗнч(Стр.ЗаказНаИзделие) = Тип("ДокументСсылка.ПМЕ_РасчетФлексопечати") тогда
    				Строка.Сумма                = ?(Стр.ЗаказНаИзделие.Тираж =0,0,Стр.ЗаказНаИзделие.СуммаСоСкидкой*Строка.Количество /Стр.ЗаказНаИзделие.Тираж);
    				
    			Иначе
    				Строка.Сумма                = Стр.ЗаказНаИзделие.СуммаСоСкидкой;
    			КонецЕсли;
    			
    			
    			Строка.СтавкаНДС            = Стр.ЗаказНаИзделие.СтавкаНДС;
    			Строка.ДатаОтгрузки        = Объект.ДатаОтгрузки;
    			Если Строка.КоличествоУпаковок <>0 Тогда
    				Строка.Цена = Окр((Строка.Сумма ) /Строка.КоличествоУпаковок, 2);
    			иначе
    				Строка.Цена = 0;
    				
    			КонецЕсли;
    			
    		КонецЦикла;
    		
    	КонецЕсли;
    
    КонецПроцедуры
    
    #КонецОбласти
    

32. Заходим в модуль документа «Заказ материалов в производство» и вносим изменения в процедуру «ПриКопировании»;

	 	// Армекс
	ПМЕ_ДокументОснование ="";
	// Армекс

33. Заходим в форму документа «Заказ поставщику» и вносим изменения в процедуру «ПослеЗаписи»;

	  	// +++ Армекс
	Оповестить("ОповещениеОбЗаписиЗаказаПоставщику",Новый Структура("Партнер",Объект.Партнер),Объект.Ссылка);
	// ---Армекс

34. Заходим в форму документа «Приобретение товаров и услуг» и вносим изменения в процедуру «ПослеЗаписи»;

	  	// +++ Армекс
	Оповестить("Запись_ПриобретениеТоваровУслугАрмекс",Новый Структура("Партнер",Объект.Партнер),Объект.Ссылка);
	// ---Армекс

35. Заходим в документ «ПроизводствоБезЗаказа»

  • на форму документа в табличную часть «Продукция» добавляем колонку «ПМЕ_ДокументОснование»;
  • на форме документа добавляем 2 команды: «ПМЕ_ЗаполнитьПоЖурналуОператора» и «ПМЕ_ЗаполнитьПоОтражениюФактаПланирования». Эти команды выносим на командную панель перед табличной частью «Продукция».
  • на форму документа добавляем все процедуры области Армекс.
    #Область ОбработчикиАрмекс
    &НаСервере
    // Функция находит всю выполненную продукцию.
    //
    Функция ЗаполнитьПоПродукции(ЭтоЖурналОператора)
    	
    	
    	ТекстЗапроса ="";
    	Если ЭтоЖурналОператора тогда
    		
    		ТекстЗапроса =	"ВЫБРАТЬ РАЗЛИЧНЫЕ
    		|	ВЫБОР
    		|		КОГДА ВложенныйЗапрос.ЗаказКлиента ССЫЛКА Документ.ПМЕ_РасчетСоставляющей
    		|			ТОГДА ВложенныйЗапрос.ЗаказКлиента.СложныйЗаказ.Продукция
    		|		КОГДА ВложенныйЗапрос.ЗаказКлиента ССЫЛКА Документ.ПМЕ_РасчетЗаказа
    		|			ТОГДА ВложенныйЗапрос.ЗаказКлиента.Продукция
    		|		ИНАЧЕ """"
    		|	КОНЕЦ КАК Номенклатура,
    		|	ВЫБОР
    		|		КОГДА ВложенныйЗапрос.ЗаказКлиента ССЫЛКА Документ.ПМЕ_РасчетСоставляющей
    		|			ТОГДА ВложенныйЗапрос.ЗаказКлиента.СложныйЗаказ.ХарактеристикаПродукции
    		|		КОГДА ВложенныйЗапрос.ЗаказКлиента ССЫЛКА Документ.ПМЕ_РасчетЗаказа
    		|			ТОГДА ВложенныйЗапрос.ЗаказКлиента.ХарактеристикаПродукции
    		|		ИНАЧЕ """"
    		|	КОНЕЦ КАК Характеристика,
    		|	СУММА(ВЫБОР
    		|			КОГДА ВложенныйЗапрос.ЗаказКлиента ССЫЛКА Документ.ПМЕ_РасчетСоставляющей
    		|				ТОГДА ВложенныйЗапрос.ЗаказКлиента.СложныйЗаказ.Тираж
    		|			ИНАЧЕ ВложенныйЗапрос.ЗаказКлиента.Тираж
    		|		КОНЕЦ) КАК Количество,
    		|	ВложенныйЗапрос.ЗаказКлиента,
    		|	ВЫБОР
    		|		КОГДА ВложенныйЗапрос.ЗаказКлиента ССЫЛКА Документ.ПМЕ_РасчетСоставляющей
    		|			ТОГДА ВложенныйЗапрос.ЗаказКлиента.СложныйЗаказ.Склад
    		|		ИНАЧЕ ВложенныйЗапрос.ЗаказКлиента.Склад
    		|	КОНЕЦ КАК Получатель,
    		|	ВЫБОР
    		|		КОГДА ВложенныйЗапрос.ЗаказКлиента ССЫЛКА Документ.ПМЕ_РасчетСоставляющей
    		|			ТОГДА ВложенныйЗапрос.ЗаказКлиента.СложныйЗаказ
    		|		ИНАЧЕ ВложенныйЗапрос.ЗаказКлиента
    		|	КОНЕЦ КАК ПМЕ_ДокументОснование
    		|ИЗ
    		|	(ВЫБРАТЬ РАЗЛИЧНЫЕ
    		|		ПМЕ_ОперацииЗаказа.ЗаказКлиента КАК ЗаказКлиента
    		|	ИЗ
    		|		РегистрСведений.ПМЕ_ОперацииЗаказа КАК ПМЕ_ОперацииЗаказа
    		|	ГДЕ
    		|		ДОБАВИТЬКДАТЕ(ДОБАВИТЬКДАТЕ(ДОБАВИТЬКДАТЕ(ПМЕ_ОперацииЗаказа.Отработан_Дата, СЕКУНДА, СЕКУНДА(ПМЕ_ОперацииЗаказа.Отработан_Время)), МИНУТА, МИНУТА(ПМЕ_ОперацииЗаказа.Отработан_Время)), ЧАС, ЧАС(ПМЕ_ОперацииЗаказа.Отработан_Время)) МЕЖДУ &ДатаНач И &ДатаКон
    		|		И (ПМЕ_ОперацииЗаказа.ЗаказКлиента ССЫЛКА Документ.ПМЕ_РасчетСоставляющей
    		|				ИЛИ ПМЕ_ОперацииЗаказа.ЗаказКлиента ССЫЛКА Документ.ПМЕ_РасчетЗаказа)
    		|		И ПМЕ_ОперацииЗаказа.Состояние = ЗНАЧЕНИЕ(Перечисление.ПМЕ_СостояниеЗаказа.Отработан)
    		|	
    		|	СГРУППИРОВАТЬ ПО
    		|		ПМЕ_ОперацииЗаказа.ЗаказКлиента) КАК ВложенныйЗапрос
    		|
    		|СГРУППИРОВАТЬ ПО
    		|	ВложенныйЗапрос.ЗаказКлиента,
    		|	ВЫБОР
    		|		КОГДА ВложенныйЗапрос.ЗаказКлиента ССЫЛКА Документ.ПМЕ_РасчетСоставляющей
    		|			ТОГДА ВложенныйЗапрос.ЗаказКлиента.СложныйЗаказ.Продукция
    		|		КОГДА ВложенныйЗапрос.ЗаказКлиента ССЫЛКА Документ.ПМЕ_РасчетЗаказа
    		|			ТОГДА ВложенныйЗапрос.ЗаказКлиента.Продукция
    		|		ИНАЧЕ """"
    		|	КОНЕЦ,
    		|	ВЫБОР
    		|		КОГДА ВложенныйЗапрос.ЗаказКлиента ССЫЛКА Документ.ПМЕ_РасчетСоставляющей
    		|			ТОГДА ВложенныйЗапрос.ЗаказКлиента.СложныйЗаказ.ХарактеристикаПродукции
    		|		КОГДА ВложенныйЗапрос.ЗаказКлиента ССЫЛКА Документ.ПМЕ_РасчетЗаказа
    		|			ТОГДА ВложенныйЗапрос.ЗаказКлиента.ХарактеристикаПродукции
    		|		ИНАЧЕ """"
    		|	КОНЕЦ,
    		|	ВЫБОР
    		|		КОГДА ВложенныйЗапрос.ЗаказКлиента ССЫЛКА Документ.ПМЕ_РасчетСоставляющей
    		|			ТОГДА ВложенныйЗапрос.ЗаказКлиента.СложныйЗаказ.Склад
    		|		ИНАЧЕ ВложенныйЗапрос.ЗаказКлиента.Склад
    		|	КОНЕЦ,
    		|	ВЫБОР
    		|		КОГДА ВложенныйЗапрос.ЗаказКлиента ССЫЛКА Документ.ПМЕ_РасчетСоставляющей
    		|			ТОГДА ВложенныйЗапрос.ЗаказКлиента.СложныйЗаказ
    		|		ИНАЧЕ ВложенныйЗапрос.ЗаказКлиента
    		|	КОНЕЦ
    		|
    		|ОБЪЕДИНИТЬ ВСЕ
    		|
    		|ВЫБРАТЬ
    		|	ВложенныйЗапрос.Номенклатура,
    		|	ВложенныйЗапрос.Характеристика,
    		|	ВложенныйЗапрос.Количество,
    		|	ВложенныйЗапрос.ЗаказКлиента,
    		|	ВложенныйЗапрос.Склад,
    		|	ВЫБОР
    		|		КОГДА ВложенныйЗапрос.ЗаказКлиента ССЫЛКА Документ.ПМЕ_РасчетСоставляющей
    		|			ТОГДА ВложенныйЗапрос.ЗаказКлиента.СложныйЗаказ
    		|		ИНАЧЕ ВложенныйЗапрос.ЗаказКлиента
    		|	КОНЕЦ
    		|ИЗ
    		|	(ВЫБРАТЬ РАЗЛИЧНЫЕ
    		|		ПМЕ_ОперацииЗаказа.ЗаказКлиента КАК ЗаказКлиента,
    		|		ПМЕ_РасчетФлексопечатиНоменклатураЗаказа.Продукция КАК Номенклатура,
    		|		ПМЕ_РасчетФлексопечатиНоменклатураЗаказа.Характеристика КАК Характеристика,
    		|		ПМЕ_РасчетФлексопечатиНоменклатураЗаказа.Тираж КАК Количество,
    		|		ПМЕ_РасчетФлексопечатиНоменклатураЗаказа.Ссылка.Склад КАК Склад
    		|	ИЗ
    		|		РегистрСведений.ПМЕ_ОперацииЗаказа КАК ПМЕ_ОперацииЗаказа
    		|			ЛЕВОЕ СОЕДИНЕНИЕ Документ.ПМЕ_РасчетФлексопечати.НоменклатураЗаказа КАК ПМЕ_РасчетФлексопечатиНоменклатураЗаказа
    		|			ПО ПМЕ_ОперацииЗаказа.ЗаказКлиента = ПМЕ_РасчетФлексопечатиНоменклатураЗаказа.Ссылка
    		|	ГДЕ
    		|		ДОБАВИТЬКДАТЕ(ДОБАВИТЬКДАТЕ(ДОБАВИТЬКДАТЕ(ПМЕ_ОперацииЗаказа.Отработан_Дата, СЕКУНДА, СЕКУНДА(ПМЕ_ОперацииЗаказа.Отработан_Время)), МИНУТА, МИНУТА(ПМЕ_ОперацииЗаказа.Отработан_Время)), ЧАС, ЧАС(ПМЕ_ОперацииЗаказа.Отработан_Время)) МЕЖДУ &ДатаНач И &ДатаКон
    		|		И ПМЕ_ОперацииЗаказа.ЗаказКлиента ССЫЛКА Документ.ПМЕ_РасчетФлексопечати
    		|		И ПМЕ_ОперацииЗаказа.Состояние = ЗНАЧЕНИЕ(Перечисление.ПМЕ_СостояниеЗаказа.Отработан)
    		|	
    		|	СГРУППИРОВАТЬ ПО
    		|		ПМЕ_ОперацииЗаказа.ЗаказКлиента,
    		|		ПМЕ_РасчетФлексопечатиНоменклатураЗаказа.Продукция,
    		|		ПМЕ_РасчетФлексопечатиНоменклатураЗаказа.Характеристика,
    		|		ПМЕ_РасчетФлексопечатиНоменклатураЗаказа.Тираж,
    		|		ПМЕ_РасчетФлексопечатиНоменклатураЗаказа.Ссылка.Склад) КАК ВложенныйЗапрос
    		|
    		|ОБЪЕДИНИТЬ ВСЕ
    		|
    		|ВЫБРАТЬ
    		|	ВложенныйЗапрос.Изделие_Название,
    		|	ВложенныйЗапрос.ХарактеристикаПродукции,
    		|	ВложенныйЗапрос.ТиражПечати,
    		|	ВложенныйЗапрос.ЗаказКлиента,
    		|	ВложенныйЗапрос.Склад,
    		|	ВЫБОР
    		|		КОГДА ВложенныйЗапрос.ЗаказКлиента ССЫЛКА Документ.ПМЕ_РасчетСоставляющей
    		|			ТОГДА ВложенныйЗапрос.ЗаказКлиента.СложныйЗаказ
    		|		ИНАЧЕ ВложенныйЗапрос.ЗаказКлиента
    		|	КОНЕЦ
    		|ИЗ
    		|	(ВЫБРАТЬ РАЗЛИЧНЫЕ
    		|		ПМЕ_ОперацииЗаказа.ЗаказКлиента КАК ЗаказКлиента,
    		|		ВЫБОР
    		|			КОГДА ПМЕ_КомпоновкаЗаказовИзделияКомпоновки.ЗаказНаИзделие ССЫЛКА Документ.ПМЕ_РасчетСоставляющей
    		|				ТОГДА ПМЕ_КомпоновкаЗаказовИзделияКомпоновки.ЗаказНаИзделие.СложныйЗаказ.Продукция
    		|			ИНАЧЕ ПМЕ_КомпоновкаЗаказовИзделияКомпоновки.Изделие_Название
    		|		КОНЕЦ КАК Изделие_Название,
    		|		ПМЕ_КомпоновкаЗаказовИзделияКомпоновки.ХарактеристикаПродукции КАК ХарактеристикаПродукции,
    		|		ПМЕ_КомпоновкаЗаказовИзделияКомпоновки.ТиражПечати КАК ТиражПечати,
    		|		ПМЕ_КомпоновкаЗаказовИзделияКомпоновки.Ссылка.Склад КАК Склад
    		|	ИЗ
    		|		РегистрСведений.ПМЕ_ОперацииЗаказа КАК ПМЕ_ОперацииЗаказа
    		|			ЛЕВОЕ СОЕДИНЕНИЕ Документ.ПМЕ_КомпоновкаЗаказов.ИзделияКомпоновки КАК ПМЕ_КомпоновкаЗаказовИзделияКомпоновки
    		|			ПО ПМЕ_ОперацииЗаказа.ЗаказКлиента = ПМЕ_КомпоновкаЗаказовИзделияКомпоновки.Ссылка
    		|	ГДЕ
    		|		ДОБАВИТЬКДАТЕ(ДОБАВИТЬКДАТЕ(ДОБАВИТЬКДАТЕ(ПМЕ_ОперацииЗаказа.Отработан_Дата, СЕКУНДА, СЕКУНДА(ПМЕ_ОперацииЗаказа.Отработан_Время)), МИНУТА, МИНУТА(ПМЕ_ОперацииЗаказа.Отработан_Время)), ЧАС, ЧАС(ПМЕ_ОперацииЗаказа.Отработан_Время)) МЕЖДУ &ДатаНач И &ДатаКон
    		|		И ПМЕ_ОперацииЗаказа.ЗаказКлиента ССЫЛКА Документ.ПМЕ_КомпоновкаЗаказов
    		|		И ПМЕ_ОперацииЗаказа.Состояние = ЗНАЧЕНИЕ(Перечисление.ПМЕ_СостояниеЗаказа.Отработан)
    		|	
    		|	СГРУППИРОВАТЬ ПО
    		|		ПМЕ_ОперацииЗаказа.ЗаказКлиента,
    		|		ПМЕ_КомпоновкаЗаказовИзделияКомпоновки.ХарактеристикаПродукции,
    		|		ПМЕ_КомпоновкаЗаказовИзделияКомпоновки.ТиражПечати,
    		|		ВЫБОР
    		|			КОГДА ПМЕ_КомпоновкаЗаказовИзделияКомпоновки.ЗаказНаИзделие ССЫЛКА Документ.ПМЕ_РасчетСоставляющей
    		|				ТОГДА ПМЕ_КомпоновкаЗаказовИзделияКомпоновки.ЗаказНаИзделие.СложныйЗаказ.Продукция
    		|			ИНАЧЕ ПМЕ_КомпоновкаЗаказовИзделияКомпоновки.Изделие_Название
    		|		КОНЕЦ,
    		|		ПМЕ_КомпоновкаЗаказовИзделияКомпоновки.Ссылка.Склад) КАК ВложенныйЗапрос";
    	Иначе
    		ТекстЗапроса =	"ВЫБРАТЬ РАЗЛИЧНЫЕ
    		|	ВЫБОР
    		|		КОГДА ВложенныйЗапрос.ЗаказКлиента ССЫЛКА Документ.ПМЕ_РасчетСоставляющей
    		|			ТОГДА ВложенныйЗапрос.ЗаказКлиента.СложныйЗаказ.Продукция
    		|		КОГДА ВложенныйЗапрос.ЗаказКлиента ССЫЛКА Документ.ПМЕ_РасчетЗаказа
    		|			ТОГДА ВложенныйЗапрос.ЗаказКлиента.Продукция
    		|		ИНАЧЕ """"
    		|	КОНЕЦ КАК Номенклатура,
    		|	ВЫБОР
    		|		КОГДА ВложенныйЗапрос.ЗаказКлиента ССЫЛКА Документ.ПМЕ_РасчетСоставляющей
    		|			ТОГДА ВложенныйЗапрос.ЗаказКлиента.СложныйЗаказ.ХарактеристикаПродукции
    		|		КОГДА ВложенныйЗапрос.ЗаказКлиента ССЫЛКА Документ.ПМЕ_РасчетЗаказа
    		|			ТОГДА ВложенныйЗапрос.ЗаказКлиента.ХарактеристикаПродукции
    		|		ИНАЧЕ """"
    		|	КОНЕЦ КАК Характеристика,
    		|	СУММА(ВЫБОР
    		|			КОГДА ВложенныйЗапрос.ЗаказКлиента ССЫЛКА Документ.ПМЕ_РасчетСоставляющей
    		|				ТОГДА ВложенныйЗапрос.ЗаказКлиента.СложныйЗаказ.Тираж
    		|			ИНАЧЕ ВложенныйЗапрос.ЗаказКлиента.Тираж
    		|		КОНЕЦ) КАК Количество,
    		|	ВложенныйЗапрос.ЗаказКлиента,
    		|	ВЫБОР
    		|		КОГДА ВложенныйЗапрос.ЗаказКлиента ССЫЛКА Документ.ПМЕ_РасчетСоставляющей
    		|			ТОГДА ВложенныйЗапрос.ЗаказКлиента.СложныйЗаказ.Склад
    		|		ИНАЧЕ ВложенныйЗапрос.ЗаказКлиента.Склад
    		|	КОНЕЦ КАК Получатель,
    		|	ВЫБОР
    		|		КОГДА ВложенныйЗапрос.ЗаказКлиента ССЫЛКА Документ.ПМЕ_РасчетСоставляющей
    		|			ТОГДА ВложенныйЗапрос.ЗаказКлиента.СложныйЗаказ
    		|		ИНАЧЕ ВложенныйЗапрос.ЗаказКлиента
    		|	КОНЕЦ КАК ПМЕ_ДокументОснование
    		|ИЗ
    		|	(ВЫБРАТЬ РАЗЛИЧНЫЕ
    		|		ОперацииПланФакт.ЗаказКлиента КАК ЗаказКлиента
    		|	ИЗ
    		|		РегистрСведений.ПМЕ_ОперацииПланФакт КАК ОперацииПланФакт
    		|	ГДЕ
    		|		ДОБАВИТЬКДАТЕ(ДОБАВИТЬКДАТЕ(ДОБАВИТЬКДАТЕ(ОперацииПланФакт.Отработан_Дата, СЕКУНДА, СЕКУНДА(ОперацииПланФакт.Отработан_Время)), МИНУТА, МИНУТА(ОперацииПланФакт.Отработан_Время)), ЧАС, ЧАС(ОперацииПланФакт.Отработан_Время)) МЕЖДУ &ДатаНач И &ДатаКон
    		|		И ОперацииПланФакт.Факт = ИСТИНА
    		|		И (ОперацииПланФакт.ЗаказКлиента ССЫЛКА Документ.ПМЕ_РасчетСоставляющей
    		|				ИЛИ ОперацииПланФакт.ЗаказКлиента ССЫЛКА Документ.ПМЕ_РасчетЗаказа)
    		|	
    		|	СГРУППИРОВАТЬ ПО
    		|		ОперацииПланФакт.ЗаказКлиента) КАК ВложенныйЗапрос
    		|
    		|СГРУППИРОВАТЬ ПО
    		|	ВложенныйЗапрос.ЗаказКлиента,
    		|	ВЫБОР
    		|		КОГДА ВложенныйЗапрос.ЗаказКлиента ССЫЛКА Документ.ПМЕ_РасчетСоставляющей
    		|			ТОГДА ВложенныйЗапрос.ЗаказКлиента.СложныйЗаказ.Продукция
    		|		КОГДА ВложенныйЗапрос.ЗаказКлиента ССЫЛКА Документ.ПМЕ_РасчетЗаказа
    		|			ТОГДА ВложенныйЗапрос.ЗаказКлиента.Продукция
    		|		ИНАЧЕ """"
    		|	КОНЕЦ,
    		|	ВЫБОР
    		|		КОГДА ВложенныйЗапрос.ЗаказКлиента ССЫЛКА Документ.ПМЕ_РасчетСоставляющей
    		|			ТОГДА ВложенныйЗапрос.ЗаказКлиента.СложныйЗаказ.ХарактеристикаПродукции
    		|		КОГДА ВложенныйЗапрос.ЗаказКлиента ССЫЛКА Документ.ПМЕ_РасчетЗаказа
    		|			ТОГДА ВложенныйЗапрос.ЗаказКлиента.ХарактеристикаПродукции
    		|		ИНАЧЕ """"
    		|	КОНЕЦ,
    		|	ВЫБОР
    		|		КОГДА ВложенныйЗапрос.ЗаказКлиента ССЫЛКА Документ.ПМЕ_РасчетСоставляющей
    		|			ТОГДА ВложенныйЗапрос.ЗаказКлиента.СложныйЗаказ.Склад
    		|		ИНАЧЕ ВложенныйЗапрос.ЗаказКлиента.Склад
    		|	КОНЕЦ,
    		|	ВЫБОР
    		|		КОГДА ВложенныйЗапрос.ЗаказКлиента ССЫЛКА Документ.ПМЕ_РасчетСоставляющей
    		|			ТОГДА ВложенныйЗапрос.ЗаказКлиента.СложныйЗаказ
    		|		ИНАЧЕ ВложенныйЗапрос.ЗаказКлиента
    		|	КОНЕЦ
    		|
    		|ОБЪЕДИНИТЬ ВСЕ
    		|
    		|ВЫБРАТЬ
    		|	ВложенныйЗапрос.Номенклатура,
    		|	ВложенныйЗапрос.Характеристика,
    		|	ВложенныйЗапрос.Количество,
    		|	ВложенныйЗапрос.ЗаказКлиента,
    		|	ВложенныйЗапрос.Склад,
    		|	ВЫБОР
    		|		КОГДА ВложенныйЗапрос.ЗаказКлиента ССЫЛКА Документ.ПМЕ_РасчетСоставляющей
    		|			ТОГДА ВложенныйЗапрос.ЗаказКлиента.СложныйЗаказ
    		|		ИНАЧЕ ВложенныйЗапрос.ЗаказКлиента
    		|	КОНЕЦ
    		|ИЗ
    		|	(ВЫБРАТЬ РАЗЛИЧНЫЕ
    		|		ОперацииПланФакт.ЗаказКлиента КАК ЗаказКлиента,
    		|		ПМЕ_РасчетФлексопечатиНоменклатураЗаказа.Продукция КАК Номенклатура,
    		|		ПМЕ_РасчетФлексопечатиНоменклатураЗаказа.Характеристика КАК Характеристика,
    		|		ПМЕ_РасчетФлексопечатиНоменклатураЗаказа.Тираж КАК Количество,
    		|		ПМЕ_РасчетФлексопечатиНоменклатураЗаказа.Ссылка.Склад КАК Склад
    		|	ИЗ
    		|		РегистрСведений.ПМЕ_ОперацииПланФакт КАК ОперацииПланФакт
    		|			ЛЕВОЕ СОЕДИНЕНИЕ Документ.ПМЕ_РасчетФлексопечати.НоменклатураЗаказа КАК ПМЕ_РасчетФлексопечатиНоменклатураЗаказа
    		|			ПО ОперацииПланФакт.ЗаказКлиента = ПМЕ_РасчетФлексопечатиНоменклатураЗаказа.Ссылка
    		|	ГДЕ
    		|		ДОБАВИТЬКДАТЕ(ДОБАВИТЬКДАТЕ(ДОБАВИТЬКДАТЕ(ОперацииПланФакт.Отработан_Дата, СЕКУНДА, СЕКУНДА(ОперацииПланФакт.Отработан_Время)), МИНУТА, МИНУТА(ОперацииПланФакт.Отработан_Время)), ЧАС, ЧАС(ОперацииПланФакт.Отработан_Время)) МЕЖДУ &ДатаНач И &ДатаКон
    		|		И ОперацииПланФакт.Факт = ИСТИНА
    		|		И ОперацииПланФакт.ЗаказКлиента ССЫЛКА Документ.ПМЕ_РасчетФлексопечати
    		|	
    		|	СГРУППИРОВАТЬ ПО
    		|		ОперацииПланФакт.ЗаказКлиента,
    		|		ПМЕ_РасчетФлексопечатиНоменклатураЗаказа.Продукция,
    		|		ПМЕ_РасчетФлексопечатиНоменклатураЗаказа.Характеристика,
    		|		ПМЕ_РасчетФлексопечатиНоменклатураЗаказа.Тираж,
    		|		ПМЕ_РасчетФлексопечатиНоменклатураЗаказа.Ссылка.Склад) КАК ВложенныйЗапрос
    		|
    		|ОБЪЕДИНИТЬ ВСЕ
    		|
    		|ВЫБРАТЬ
    		|	ВложенныйЗапрос.Изделие_Название,
    		|	ВложенныйЗапрос.ХарактеристикаПродукции,
    		|	ВложенныйЗапрос.ТиражПечати,
    		|	ВложенныйЗапрос.ЗаказКлиента,
    		|	ВложенныйЗапрос.Склад,
    		|	ВЫБОР
    		|		КОГДА ВложенныйЗапрос.ЗаказКлиента ССЫЛКА Документ.ПМЕ_РасчетСоставляющей
    		|			ТОГДА ВложенныйЗапрос.ЗаказКлиента.СложныйЗаказ
    		|		ИНАЧЕ ВложенныйЗапрос.ЗаказКлиента
    		|	КОНЕЦ
    		|ИЗ
    		|	(ВЫБРАТЬ РАЗЛИЧНЫЕ
    		|		ОперацииПланФакт.ЗаказКлиента КАК ЗаказКлиента,
    		|		ВЫБОР
    		|			КОГДА ПМЕ_КомпоновкаЗаказовИзделияКомпоновки.ЗаказНаИзделие ССЫЛКА Документ.ПМЕ_РасчетСоставляющей
    		|				ТОГДА ПМЕ_КомпоновкаЗаказовИзделияКомпоновки.ЗаказНаИзделие.СложныйЗаказ.Продукция
    		|			ИНАЧЕ ПМЕ_КомпоновкаЗаказовИзделияКомпоновки.Изделие_Название
    		|		КОНЕЦ КАК Изделие_Название,
    		|		ПМЕ_КомпоновкаЗаказовИзделияКомпоновки.ХарактеристикаПродукции КАК ХарактеристикаПродукции,
    		|		ПМЕ_КомпоновкаЗаказовИзделияКомпоновки.ТиражПечати КАК ТиражПечати,
    		|		ПМЕ_КомпоновкаЗаказовИзделияКомпоновки.Ссылка.Склад КАК Склад
    		|	ИЗ
    		|		РегистрСведений.ПМЕ_ОперацииПланФакт КАК ОперацииПланФакт
    		|			ЛЕВОЕ СОЕДИНЕНИЕ Документ.ПМЕ_КомпоновкаЗаказов.ИзделияКомпоновки КАК ПМЕ_КомпоновкаЗаказовИзделияКомпоновки
    		|			ПО ОперацииПланФакт.ЗаказКлиента = ПМЕ_КомпоновкаЗаказовИзделияКомпоновки.Ссылка
    		|	ГДЕ
    		|		ДОБАВИТЬКДАТЕ(ДОБАВИТЬКДАТЕ(ДОБАВИТЬКДАТЕ(ОперацииПланФакт.Отработан_Дата, СЕКУНДА, СЕКУНДА(ОперацииПланФакт.Отработан_Время)), МИНУТА, МИНУТА(ОперацииПланФакт.Отработан_Время)), ЧАС, ЧАС(ОперацииПланФакт.Отработан_Время)) МЕЖДУ &ДатаНач И &ДатаКон
    		|		И ОперацииПланФакт.Факт = ИСТИНА
    		|		И ОперацииПланФакт.ЗаказКлиента ССЫЛКА Документ.ПМЕ_КомпоновкаЗаказов
    		|	
    		|	СГРУППИРОВАТЬ ПО
    		|		ОперацииПланФакт.ЗаказКлиента,
    		|		ПМЕ_КомпоновкаЗаказовИзделияКомпоновки.ХарактеристикаПродукции,
    		|		ПМЕ_КомпоновкаЗаказовИзделияКомпоновки.ТиражПечати,
    		|		ВЫБОР
    		|			КОГДА ПМЕ_КомпоновкаЗаказовИзделияКомпоновки.ЗаказНаИзделие ССЫЛКА Документ.ПМЕ_РасчетСоставляющей
    		|				ТОГДА ПМЕ_КомпоновкаЗаказовИзделияКомпоновки.ЗаказНаИзделие.СложныйЗаказ.Продукция
    		|			ИНАЧЕ ПМЕ_КомпоновкаЗаказовИзделияКомпоновки.Изделие_Название
    		|		КОНЕЦ,
    		|		ПМЕ_КомпоновкаЗаказовИзделияКомпоновки.Ссылка.Склад) КАК ВложенныйЗапрос";
    		
    	КонецЕсли;
    	
    	возврат ТекстЗапроса;
    	
    	
    	
    	
    КонецФункции  // 
    
    &НаСервере
    // Функция находит потраченные материалы .
    //
    Функция ЗаполнитьПоМатериалыПродукции(ЭтоЖурналОператора)
    	
    	
    	ТекстЗапроса ="";
    	Если ЭтоЖурналОператора тогда
    		
    		ТекстЗапроса =	"ВЫБРАТЬ
    		              	|	ФактическийМатериал.Номенклатура КАК Номенклатура,
    		              	|	ФактическийМатериал.Характеристика КАК Характеристика,
    		              	|	СУММА(ФактическийМатериал.КоличествоПоФакту) КАК Количество,
    		              	|	СУММА(ФактическийМатериал.КоличествоПоФакту) КАК КоличествоУпаковок,
    		              	|	&НомерГруппыЗатрат КАК НомерГруппыЗатрат,
    		              	|	ВЫБОР
    		              	|		КОГДА ФактическийМатериал.ЗаказКлиента ССЫЛКА Документ.ПМЕ_РасчетСоставляющей
    		              	|			ТОГДА ФактическийМатериал.ЗаказКлиента.СложныйЗаказ.СкладМатериалов
    		              	|		ИНАЧЕ ФактическийМатериал.ЗаказКлиента.СкладМатериалов
    		              	|	КОНЕЦ КАК Склад,
    		              	|	ФактическийМатериал.Номенклатура.ПМЕ_ОсновнаяСтатьяЗатратНаПроизводство КАК СтатьяКалькуляции,
    		              	|	ФактическийМатериал.ЕдиницаИзмеренияФакт КАК ЕдиницаИзмеренияФакт,
    		              	|	ВЫБОР
    		              	|		КОГДА ФактическийМатериал.ЗаказКлиента ССЫЛКА Документ.ПМЕ_РасчетСоставляющей
    		              	|			ТОГДА ФактическийМатериал.ЗаказКлиента.СложныйЗаказ.Подразделение
    		              	|		ИНАЧЕ ФактическийМатериал.ЗаказКлиента.Подразделение
    		              	|	КОНЕЦ КАК Подразделение
    		              	|ИЗ
    		              	|	РегистрСведений.ПМЕ_ОперацииЗаказа КАК ПМЕ_ОперацииЗаказа
    		              	|		ВНУТРЕННЕЕ СОЕДИНЕНИЕ (ВЫБРАТЬ
    		              	|			ПМЕ_МатериалыЗаказа.ЗаказКлиента КАК ЗаказКлиента,
    		              	|			ПМЕ_МатериалыЗаказа.ОперацияЗаказа КАК ОперацияЗаказа,
    		              	|			ПМЕ_МатериалыЗаказа.НомерСтрокиДокумента КАК НомерСтрокиДокумента,
    		              	|			ПМЕ_МатериалыЗаказа.Номенклатура КАК Номенклатура,
    		              	|			ПМЕ_МатериалыЗаказа.Характеристика КАК Характеристика,
    		              	|			ПМЕ_МатериалыЗаказа.КоличествоПоФакту КАК КоличествоПоФакту,
    		              	|			ПМЕ_МатериалыЗаказа.ЕдиницаИзмеренияФакт КАК ЕдиницаИзмеренияФакт
    		              	|		ИЗ
    		              	|			РегистрСведений.ПМЕ_МатериалыЗаказа КАК ПМЕ_МатериалыЗаказа
    		              	|		ГДЕ
    		              	|			ПМЕ_МатериалыЗаказа.КоличествоПоФакту > 0
    		              	|			И ПМЕ_МатериалыЗаказа.ЗаказКлиента = &ЗаказКлиента) КАК ФактическийМатериал
    		              	|		ПО ПМЕ_ОперацииЗаказа.ЗаказКлиента = ФактическийМатериал.ЗаказКлиента
    		              	|			И ПМЕ_ОперацииЗаказа.НомерСтрокиДокумента = ФактическийМатериал.НомерСтрокиДокумента
    		              	|			И ПМЕ_ОперацииЗаказа.ОперацияЗаказа = ФактическийМатериал.ОперацияЗаказа
    		              	|ГДЕ
    		              	|	ДОБАВИТЬКДАТЕ(ДОБАВИТЬКДАТЕ(ДОБАВИТЬКДАТЕ(ПМЕ_ОперацииЗаказа.Отработан_Дата, СЕКУНДА, СЕКУНДА(ПМЕ_ОперацииЗаказа.Отработан_Время)), МИНУТА, МИНУТА(ПМЕ_ОперацииЗаказа.Отработан_Время)), ЧАС, ЧАС(ПМЕ_ОперацииЗаказа.Отработан_Время)) МЕЖДУ &ДатаНач И &ДатаКон
    		              	|	И ПМЕ_ОперацииЗаказа.ЗаказКлиента = &ЗаказКлиента
    		              	|
    		              	|СГРУППИРОВАТЬ ПО
    		              	|	ФактическийМатериал.Номенклатура,
    		              	|	ФактическийМатериал.Характеристика,
    		              	|	ВЫБОР
    		              	|		КОГДА ФактическийМатериал.ЗаказКлиента ССЫЛКА Документ.ПМЕ_РасчетСоставляющей
    		              	|			ТОГДА ФактическийМатериал.ЗаказКлиента.СложныйЗаказ.СкладМатериалов
    		              	|		ИНАЧЕ ФактическийМатериал.ЗаказКлиента.СкладМатериалов
    		              	|	КОНЕЦ,
    		              	|	ФактическийМатериал.Номенклатура.ПМЕ_ОсновнаяСтатьяЗатратНаПроизводство,
    		              	|	ФактическийМатериал.ЕдиницаИзмеренияФакт,
    		              	|	ВЫБОР
    		              	|		КОГДА ФактическийМатериал.ЗаказКлиента ССЫЛКА Документ.ПМЕ_РасчетСоставляющей
    		              	|			ТОГДА ФактическийМатериал.ЗаказКлиента.СложныйЗаказ.Подразделение
    		              	|		ИНАЧЕ ФактическийМатериал.ЗаказКлиента.Подразделение
    		              	|	КОНЕЦ";
    	Иначе
    		ТекстЗапроса =	"ВЫБРАТЬ
    		              	|	ФактическийМатериал.Номенклатура КАК Номенклатура,
    		              	|	ФактическийМатериал.Характеристика КАК Характеристика,
    		              	|	СУММА(ФактическийМатериал.КоличествоПоФакту) КАК Количество,
    		              	|	СУММА(ФактическийМатериал.КоличествоПоФакту) КАК КоличествоУпаковок,
    		              	|	&НомерГруппыЗатрат КАК НомерГруппыЗатрат,
    		              	|	ВЫБОР
    		              	|		КОГДА ФактическийМатериал.ЗаказКлиента ССЫЛКА Документ.ПМЕ_РасчетСоставляющей
    		              	|			ТОГДА ФактическийМатериал.ЗаказКлиента.СложныйЗаказ.СкладМатериалов
    		              	|		ИНАЧЕ ФактическийМатериал.ЗаказКлиента.СкладМатериалов
    		              	|	КОНЕЦ КАК Склад,
    		              	|	ФактическийМатериал.Номенклатура.ПМЕ_ОсновнаяСтатьяЗатратНаПроизводство КАК СтатьяКалькуляции,
    		              	|	ФактическийМатериал.ЕдиницаИзмеренияФакт КАК ЕдиницаИзмеренияФакт,
    		              	|	ВЫБОР
    		              	|		КОГДА ФактическийМатериал.ЗаказКлиента ССЫЛКА Документ.ПМЕ_РасчетСоставляющей
    		              	|			ТОГДА ФактическийМатериал.ЗаказКлиента.СложныйЗаказ.Подразделение
    		              	|		ИНАЧЕ ФактическийМатериал.ЗаказКлиента.Подразделение
    		              	|	КОНЕЦ КАК Подразделение
    		              	|ИЗ
    		              	|	РегистрСведений.ПМЕ_ОперацииПланФакт КАК ОперацииПланФакт
    		              	|		ВНУТРЕННЕЕ СОЕДИНЕНИЕ (ВЫБРАТЬ
    		              	|			МатериалыЗаказаПланФакт.ЗаказКлиента КАК ЗаказКлиента,
    		              	|			МатериалыЗаказаПланФакт.ОперацияЗаказа КАК ОперацияЗаказа,
    		              	|			МатериалыЗаказаПланФакт.НомерСтрокиДокумента КАК НомерСтрокиДокумента,
    		              	|			МатериалыЗаказаПланФакт.НомерУникальности КАК НомерУникальности,
    		              	|			МатериалыЗаказаПланФакт.Номенклатура КАК Номенклатура,
    		              	|			МатериалыЗаказаПланФакт.Характеристика КАК Характеристика,
    		              	|			МатериалыЗаказаПланФакт.КоличествоПоФакту КАК КоличествоПоФакту,
    		              	|			МатериалыЗаказаПланФакт.ЕдиницаИзмеренияФакт КАК ЕдиницаИзмеренияФакт
    		              	|		ИЗ
    		              	|			РегистрСведений.ПМЕ_МатериалыЗаказаПланФакт КАК МатериалыЗаказаПланФакт
    		              	|		ГДЕ
    		              	|			МатериалыЗаказаПланФакт.КоличествоПоФакту > 0
    		              	|			И МатериалыЗаказаПланФакт.ЗаказКлиента = &ЗаказКлиента) КАК ФактическийМатериал
    		              	|		ПО ОперацииПланФакт.ЗаказКлиента = ФактическийМатериал.ЗаказКлиента
    		              	|			И ОперацииПланФакт.НомерСтрокиДокумента = ФактическийМатериал.НомерСтрокиДокумента
    		              	|			И ОперацииПланФакт.НомерУникальности = ФактическийМатериал.НомерУникальности
    		              	|			И ОперацииПланФакт.ОперацияЗаказа = ФактическийМатериал.ОперацияЗаказа
    		              	|ГДЕ
    		              	|	ДОБАВИТЬКДАТЕ(ДОБАВИТЬКДАТЕ(ДОБАВИТЬКДАТЕ(ОперацииПланФакт.Отработан_Дата, СЕКУНДА, СЕКУНДА(ОперацииПланФакт.Отработан_Время)), МИНУТА, МИНУТА(ОперацииПланФакт.Отработан_Время)), ЧАС, ЧАС(ОперацииПланФакт.Отработан_Время)) МЕЖДУ &ДатаНач И &ДатаКон
    		              	|	И ОперацииПланФакт.Факт = ИСТИНА
    		              	|	И ОперацииПланФакт.ЗаказКлиента = &ЗаказКлиента
    		              	|
    		              	|СГРУППИРОВАТЬ ПО
    		              	|	ФактическийМатериал.Номенклатура,
    		              	|	ФактическийМатериал.Характеристика,
    		              	|	ВЫБОР
    		              	|		КОГДА ФактическийМатериал.ЗаказКлиента ССЫЛКА Документ.ПМЕ_РасчетСоставляющей
    		              	|			ТОГДА ФактическийМатериал.ЗаказКлиента.СложныйЗаказ.СкладМатериалов
    		              	|		ИНАЧЕ ФактическийМатериал.ЗаказКлиента.СкладМатериалов
    		              	|	КОНЕЦ,
    		              	|	ФактическийМатериал.Номенклатура.ПМЕ_ОсновнаяСтатьяЗатратНаПроизводство,
    		              	|	ФактическийМатериал.ЕдиницаИзмеренияФакт,
    		              	|	ВЫБОР
    		              	|		КОГДА ФактическийМатериал.ЗаказКлиента ССЫЛКА Документ.ПМЕ_РасчетСоставляющей
    		              	|			ТОГДА ФактическийМатериал.ЗаказКлиента.СложныйЗаказ.Подразделение
    		              	|		ИНАЧЕ ФактическийМатериал.ЗаказКлиента.Подразделение
    		              	|	КОНЕЦ";
    		
    	КонецЕсли;	
    	возврат ТекстЗапроса;
    	
    	
    КонецФункции  // 
    
    &НаСервере
    // Функция находит все виды работ.
    //
    Функция ЗаполнитьПоТрудозатратам(ЭтоЖурналОператора)
    	
    	
    	ТекстЗапроса ="";
    	Если ЭтоЖурналОператора тогда
    		
    		ТекстЗапроса =	"ВЫБРАТЬ
    		|	ВложенныйЗапрос.ОперацияЗаказаВидРабот КАК ВидРабот,
    		|	СУММА(ВложенныйЗапрос.Количество) КАК Количество,
    		|	ВложенныйЗапрос.ОперацияЗаказа КАК ОперацияЗаказа
    		|ИЗ
    		|	(ВЫБРАТЬ
    		|		ПМЕ_ОперацииЗаказа.ОперацияЗаказа.ВидРабот КАК ОперацияЗаказаВидРабот,
    		|		ВЫБОР
    		|			КОГДА ПМЕ_ОперацииЗаказа.ОперацияЗаказа.ОТКоличества = 0
    		|				ТОГДА ПМЕ_ОперацииЗаказа.ТиражПоФакту
    		|			ИНАЧЕ ВЫБОР
    		|					КОГДА НЕ ПМЕ_ОперацииЗаказа.Отработан_Дата = ДАТАВРЕМЯ(1, 1, 1)
    		|							И НЕ ПМЕ_ОперацииЗаказа.Отработан_Время = ДАТАВРЕМЯ(1, 1, 1)
    		|							И НЕ ПМЕ_ОперацииЗаказа.ВРаботе_Время = ДАТАВРЕМЯ(1, 1, 1)
    		|							И НЕ ПМЕ_ОперацииЗаказа.ВРаботе_Дата = ДАТАВРЕМЯ(1, 1, 1)
    		|						ТОГДА РАЗНОСТЬДАТ(ПМЕ_ОперацииЗаказа.ВРаботе_Дата, ПМЕ_ОперацииЗаказа.Отработан_Дата, СЕКУНДА) + РАЗНОСТЬДАТ(ПМЕ_ОперацииЗаказа.ВРаботе_Время, ПМЕ_ОперацииЗаказа.Отработан_Время, СЕКУНДА)
    		|					ИНАЧЕ 0
    		|				КОНЕЦ
    		|		КОНЕЦ КАК Количество,
    		|		ПМЕ_ОперацииЗаказа.ОперацияЗаказа КАК ОперацияЗаказа
    		|	ИЗ
    		|		РегистрСведений.ПМЕ_ОперацииЗаказа КАК ПМЕ_ОперацииЗаказа
    		|	ГДЕ
    		|		ДОБАВИТЬКДАТЕ(ДОБАВИТЬКДАТЕ(ДОБАВИТЬКДАТЕ(ПМЕ_ОперацииЗаказа.Отработан_Дата, СЕКУНДА, СЕКУНДА(ПМЕ_ОперацииЗаказа.Отработан_Время)), МИНУТА, МИНУТА(ПМЕ_ОперацииЗаказа.Отработан_Время)), ЧАС, ЧАС(ПМЕ_ОперацииЗаказа.Отработан_Время)) МЕЖДУ &ДатаНач И &ДатаКон
    		|		И ПМЕ_ОперацииЗаказа.ОперацияЗаказа.ИспользоватьДлярасчетаЗарплаты = ИСТИНА
    		|		И ПМЕ_ОперацииЗаказа.ЗаказКлиента = &ЗаказКлиента) КАК ВложенныйЗапрос
    		|ГДЕ
    		|	ВложенныйЗапрос.ОперацияЗаказаВидРабот.Ссылка <> ЗНАЧЕНИЕ(Справочник.ВидыРаботСотрудников.ПустаяСсылка)
    		|
    		|СГРУППИРОВАТЬ ПО
    		|	ВложенныйЗапрос.ОперацияЗаказаВидРабот,
    		|	ВложенныйЗапрос.ОперацияЗаказа";
    	Иначе
    		ТекстЗапроса =	"ВЫБРАТЬ
    		|	ВложенныйЗапрос.ОперацияЗаказаВидРабот КАК ВидРабот,
    		|	СУММА(ВложенныйЗапрос.Количество) КАК Количество,
    		|	ВложенныйЗапрос.ОперацияЗаказа КАК ОперацияЗаказа
    		|ИЗ
    		|	(ВЫБРАТЬ
    		|		ОперацииПланФакт.ОперацияЗаказа.ВидРабот КАК ОперацияЗаказаВидРабот,
    		|		ВЫБОР
    		|			КОГДА ОперацииПланФакт.ОперацияЗаказа.ОТКоличества = 0
    		|				ТОГДА ОперацииПланФакт.ТиражПоФакту
    		|			ИНАЧЕ ВЫБОР
    		|					КОГДА НЕ ОперацииПланФакт.Отработан_Дата = ДАТАВРЕМЯ(1, 1, 1)
    		|							И НЕ ОперацииПланФакт.Отработан_Время = ДАТАВРЕМЯ(1, 1, 1)
    		|							И НЕ ОперацииПланФакт.ВРаботе_Время = ДАТАВРЕМЯ(1, 1, 1)
    		|							И НЕ ОперацииПланФакт.ВРаботе_Дата = ДАТАВРЕМЯ(1, 1, 1)
    		|						ТОГДА РАЗНОСТЬДАТ(ОперацииПланФакт.ВРаботе_Дата, ОперацииПланФакт.Отработан_Дата, СЕКУНДА) + РАЗНОСТЬДАТ(ОперацииПланФакт.ВРаботе_Время, ОперацииПланФакт.Отработан_Время, СЕКУНДА)
    		|					ИНАЧЕ 0
    		|				КОНЕЦ
    		|		КОНЕЦ КАК Количество,
    		|		ОперацииПланФакт.ОперацияЗаказа КАК ОперацияЗаказа
    		|	ИЗ
    		|		РегистрСведений.ПМЕ_ОперацииПланФакт КАК ОперацииПланФакт
    		|	ГДЕ
    		|		ДОБАВИТЬКДАТЕ(ДОБАВИТЬКДАТЕ(ДОБАВИТЬКДАТЕ(ОперацииПланФакт.Отработан_Дата, СЕКУНДА, СЕКУНДА(ОперацииПланФакт.Отработан_Время)), МИНУТА, МИНУТА(ОперацииПланФакт.Отработан_Время)), ЧАС, ЧАС(ОперацииПланФакт.Отработан_Время)) МЕЖДУ &ДатаНач И &ДатаКон
    		|		И ОперацииПланФакт.Факт = ИСТИНА
    		|		И ОперацииПланФакт.ОперацияЗаказа.ИспользоватьДлярасчетаЗарплаты = ИСТИНА
    		|		И ОперацииПланФакт.ЗаказКлиента = &ЗаказКлиента) КАК ВложенныйЗапрос
    		|ГДЕ
    		|	ВложенныйЗапрос.ОперацияЗаказаВидРабот.Ссылка <> ЗНАЧЕНИЕ(Справочник.ВидыРаботСотрудников.ПустаяСсылка)
    		|
    		|СГРУППИРОВАТЬ ПО
    		|	ВложенныйЗапрос.ОперацияЗаказаВидРабот,
    		|	ВложенныйЗапрос.ОперацияЗаказа";
    		
    	КонецЕсли;		
    	возврат ТекстЗапроса;
    	
    	
    КонецФункции  // 
    
    &НаСервере
    // Процедура заполняет табличную часть "Операции".
    //
    Процедура ПМЕ_ЗаполнитьПоОперациям(ДатаНач, ДатаКон,ЭтоЖурналОператора)
    // Продукция   
    	Запрос = Новый Запрос;
    	Запрос.Текст = ЗаполнитьПоПродукции(ЭтоЖурналОператора);
    	Запрос.УстановитьПараметр("ДатаКон", ДатаКон);
    	Запрос.УстановитьПараметр("ДатаНач", ДатаНач);
    	Результат  = Запрос.Выполнить().Выгрузить();
    	
    	Для Каждого стр из Результат цикл  
    		НоваяСтрока = Объект.ВыходныеИзделия.Добавить();
    		НоваяСтрока.Получатель        = стр.Получатель;
    		НоваяСтрока.ПМЕ_ДокументОснование        = стр.ПМЕ_ДокументОснование;
    		НоваяСтрока.Номенклатура        = стр.Номенклатура;
    		НоваяСтрока.Характеристика   = стр.Характеристика;
    		НоваяСтрока.Количество   =  стр.Количество;
    		НоваяСтрока.КоличествоУпаковок   =  НоваяСтрока.Количество;
    		НоваяСтрока.НомерГруппыЗатрат           = НоваяСтрока.НомерСтроки;
    		// Материалы 
    		ЗапросМатериалы = Новый Запрос;
    		ЗапросМатериалы.Текст = ЗаполнитьПоМатериалыПродукции(ЭтоЖурналОператора);
    		ЗапросМатериалы.УстановитьПараметр("ДатаКон", ДатаКон);
    		ЗапросМатериалы.УстановитьПараметр("ДатаНач", ДатаНач);
    		ЗапросМатериалы.УстановитьПараметр("ЗаказКлиента", стр.ЗаказКлиента);
    		ЗапросМатериалы.УстановитьПараметр("НомерГруппыЗатрат",  НоваяСтрока.НомерСтроки);
    		//ФормаДокумента.МатериалыИРаботы.Загрузить( ЗапросМатериалы.Выполнить().Выгрузить());
    		РезультатМатериалы =ЗапросМатериалы.Выполнить().Выгрузить();
    		Для Каждого стрМатериала из РезультатМатериалы цикл  
    			НоваяСтрокастрМатериал = Объект.МатериалыИРаботы.Добавить();
    			ЗаполнитьЗначенияСвойств(НоваяСтрокастрМатериал,стрМатериала);
    				Если    стрМатериала.ЕдиницаИзмеренияФакт <>  стрМатериала.Номенклатура.ЕдиницаИзмерения тогда
    				 ШиринаРоля=0;
    					 Плотность =0;
    					 ФорматШирина=0;
    					 ФорматДлина=0;
    					 
    					 Если ЗначениеЗаполнено(стрМатериала.Характеристика) Тогда
    						 //
    						 Запрос = Новый  Запрос;
    						 Запрос.Текст = "ВЫБРАТЬ
    						 |	ХарактеристикиНоменклатурыДополнительныеРеквизиты.Значение,
    						 |	ХарактеристикиНоменклатурыДополнительныеРеквизиты.Свойство
    						 |ИЗ
    						 |	Справочник.ХарактеристикиНоменклатуры.ДополнительныеРеквизиты КАК ХарактеристикиНоменклатурыДополнительныеРеквизиты
    						 |ГДЕ
    						 |	ХарактеристикиНоменклатурыДополнительныеРеквизиты.Ссылка = &Объект
    						 |	И (ХарактеристикиНоменклатурыДополнительныеРеквизиты.Значение ССЫЛКА Справочник.ПМЕ_Плотность
    						 |			ИЛИ ХарактеристикиНоменклатурыДополнительныеРеквизиты.Значение ССЫЛКА Справочник.ПМЕ_Формат)";
    						 Запрос.УстановитьПараметр("Объект",стрМатериала.Характеристика);			
    						 Таб = Запрос.Выполнить().Выгрузить();
    						 Для Каждого Стр1 Из Таб Цикл
    							 Если ТипЗнч(Стр1.Значение) = Тип("СправочникСсылка.ПМЕ_Формат") Тогда
    								 ФорматШирина=Стр1.Значение.Ширина;
    								 ФорматДлина=Стр1.Значение.Длина;
    								 прервать;
    							 КонецЕсли;
    						 КонецЦикла;
    						 Для Каждого Стр Из Таб Цикл
    							 Если ТипЗнч(Стр.Значение) = Тип("СправочникСсылка.ПМЕ_Плотность") Тогда
    								 Плотность = Стр.Значение.Плотность;
    								 прервать;
    							 КонецЕсли;
    						 КонецЦикла;
    						 
    						 // ширина роля
    						 
    						 	
    							Запрос = Новый  Запрос;
    							Запрос.Текст = "ВЫБРАТЬ
    							|	ХарактеристикиНоменклатурыДополнительныеРеквизиты.Значение КАК ШиринаРоля
    							|ИЗ
    							|	Справочник.ХарактеристикиНоменклатуры.ДополнительныеРеквизиты КАК ХарактеристикиНоменклатурыДополнительныеРеквизиты
    							|ГДЕ
    							|	ХарактеристикиНоменклатурыДополнительныеРеквизиты.Ссылка = &Объект
    							|	И ХарактеристикиНоменклатурыДополнительныеРеквизиты.Свойство = ЗНАЧЕНИЕ(ПланВидовХарактеристик.ДополнительныеРеквизитыИСведения.ШиринаРоля)";
    							Запрос.УстановитьПараметр("Объект",стрМатериала.Характеристика);			
    							Таб = Запрос.Выполнить().Выгрузить();
    							Если Таб.Количество() >0 тогда
    								ШиринаРоля=Таб[0].ШиринаРоля;
    							КонецЕсли;
    							Если ШиринаРоля =0 и  ФорматШирина<>0 тогда
    								 ШиринаРоля =ФорматШирина;
    							КонецЕсли;
    					 КонецЕсли;
    
    					Если   стрМатериала.Номенклатура.ЕдиницаИзмерения =  Константы.ЕдиницаИзмеренияВеса.Получить() тогда    // кг
    						
    						Если  стрМатериала.ЕдиницаИзмеренияФакт =  Константы.ПМЕ_Лист.Получить() тогда  // лист							
    							  НоваяСтрокастрМатериал.Количество =НоваяСтрокастрМатериал.Количество* ((ФорматШирина*ФорматДлина)/1000000)*Плотность/1000;  // из листов в кг
    						ИначеЕсли 	 стрМатериала.ЕдиницаИзмеренияФакт =  Константы.ПМЕ_КвадратныйМетр.Получить() тогда // м2
    							  НоваяСтрокастрМатериал.Количество =НоваяСтрокастрМатериал.Количество*Плотность/1000;  // из м2 в кг
    						ИначеЕсли 	  стрМатериала.ЕдиницаИзмеренияФакт=  Константы.ПМЕ_ПогонныйМетр.Получить() тогда // пог. м							
    							  НоваяСтрокастрМатериал.Количество =НоваяСтрокастрМатериал.Количество*  ШиринаРоля/1000*Плотность/1000;  // из пог. м	 в кг
    						КонецЕсли;
    
    					ИначеЕсли 	  стрМатериала.Номенклатура.ЕдиницаИзмерения=  Константы.ПМЕ_КвадратныйМетр.Получить() тогда // м2
    						 
    						Если  стрМатериала.ЕдиницаИзмеренияФакт =  Константы.ЕдиницаИзмеренияВеса.Получить() тогда  
    							Если  (Плотность)/1000 =0 тогда
    								НоваяСтрокастрМатериал.Количество       = 0;
    							иначе
    								НоваяСтрокастрМатериал.Количество =НоваяСтрокастрМатериал.Количество/((Плотность)/1000);
    							КонецЕсли;
    
    						ИначеЕсли	стрМатериала.ЕдиницаИзмеренияФакт =  Константы.ПМЕ_Лист.Получить() тогда  // лист							
    								НоваяСтрокастрМатериал.Количество =НоваяСтрокастрМатериал.Количество*((ФорматШирина*ФорматДлина)/1000000);
    							
    						ИначеЕсли 	  стрМатериала.ЕдиницаИзмеренияФакт=  Константы.ПМЕ_ПогонныйМетр.Получить() тогда // пог. м							
    								НоваяСтрокастрМатериал.Количество =НоваяСтрокастрМатериал.Количество*((ФорматШирина)/1000);
    						КонецЕсли;
    
    					ИначеЕсли 	 стрМатериала.Номенклатура.ЕдиницаИзмерения =  Константы.ПМЕ_ПогонныйМетр.Получить() тогда
    						
    						Если   стрМатериала.ЕдиницаИзмеренияФакт =  Константы.ЕдиницаИзмеренияВеса.Получить() тогда  // кг							
    							Если  (ШиринаРоля*Плотность)/1000000 =0 тогда
    								НоваяСтрокастрМатериал.Количество       = 0;
    							иначе
    								НоваяСтрокастрМатериал.Количество =НоваяСтрокастрМатериал.Количество/((ШиринаРоля*Плотность)/1000000);
    							КонецЕсли;							
    						ИначеЕсли 	  стрМатериала.ЕдиницаИзмеренияФакт =  Константы.ПМЕ_КвадратныйМетр.Получить() тогда // м2
    							  Если  (ШиринаРоля)/1000 =0 тогда
    								НоваяСтрокастрМатериал.Количество       = 0;
    							иначе
    								НоваяСтрокастрМатериал.Количество =НоваяСтрокастрМатериал.Количество/((ШиринаРоля)/1000);
    							КонецЕсли;	
    							
    						ИначеЕсли 	  стрМатериала.ЕдиницаИзмеренияФакт=  Константы.ПМЕ_Лист.Получить() тогда // пог. м							
    							НоваяСтрокастрМатериал.Количество  =  НоваяСтрокастрМатериал.Количество*(ФорматДлина)/1000;// перевод листов в погонные метры						
    						КонецЕсли;
    						
    						
    					ИначеЕсли 	 стрМатериала.Номенклатура.ЕдиницаИзмерения =  Константы.ПМЕ_Лист.Получить() тогда  // лист
    						
    						Если   стрМатериала.ЕдиницаИзмеренияФакт =  Константы.ЕдиницаИзмеренияВеса.Получить() тогда  // кг								
    							Если  (ФорматШирина*ФорматДлина*Плотность)/1000000000 =0 тогда
    								НоваяСтрокастрМатериал.Количество       = 0;
    							иначе
    								НоваяСтрокастрМатериал.Количество =НоваяСтрокастрМатериал.Количество/((ФорматШирина*ФорматДлина*Плотность)/1000000000 );
    							КонецЕсли;
    						ИначеЕсли 	  стрМатериала.ЕдиницаИзмеренияФакт=  Константы.ПМЕ_ПогонныйМетр.Получить() тогда // пог. м							
    							 Если  (ФорматДлина)/1000 =0 тогда
    								НоваяСтрокастрМатериал.Количество       = 0;
    							иначе
    								НоваяСтрокастрМатериал.Количество =НоваяСтрокастрМатериал.Количество/((ФорматДлина)/1000 );
    							КонецЕсли;
    
    							
    						ИначеЕсли 	стрМатериала.ЕдиницаИзмеренияФакт=  Константы.ПМЕ_КвадратныйМетр.Получить() тогда // м2
    						     Если  (ФорматШирина*ФорматДлина)/1000000 =0 тогда
    								НоваяСтрокастрМатериал.Количество       = 0;
    							иначе
    								НоваяСтрокастрМатериал.Количество =НоваяСтрокастрМатериал.Количество/((ФорматШирина*ФорматДлина)/1000000 );
    							КонецЕсли;
    
    							
    						КонецЕсли;
    					КонецЕсли;
    					
    
    			КонецЕсли;
    
    		КонецЦикла;
    
    		// Трудозатраты 
    		ЗапросТрудозатраты = Новый Запрос;
    		ЗапросТрудозатраты.Текст = ЗаполнитьПоТрудозатратам(ЭтоЖурналОператора);
    		ЗапросТрудозатраты.УстановитьПараметр("ДатаКон", ДатаКон);
    		ЗапросТрудозатраты.УстановитьПараметр("ДатаНач", ДатаНач);
    		ЗапросТрудозатраты.УстановитьПараметр("ЗаказКлиента", стр.ЗаказКлиента);
    
    		РезультатТрудозатраты =ЗапросТрудозатраты.Выполнить().Выгрузить();
    		Для Каждого стрТрудозатраты из РезультатТрудозатраты цикл  
    			НоваяСтрокастрТрудозатраты = Объект.Трудозатраты.Добавить();
    			НоваяСтрокастрТрудозатраты.ВидРабот        = стрТрудозатраты.ВидРабот;
    			НоваяСтрокастрТрудозатраты.Количество   = стрТрудозатраты.Количество;
    			НоваяСтрокастрТрудозатраты.СтатьяКалькуляции   =  стрТрудозатраты.ОперацияЗаказа.ОсновнаяСтатьяЗатратНаПроизводство;
    			НоваяСтрокастрТрудозатраты.НомерГруппыЗатрат           = НоваяСтрока.НомерСтроки;
    
    		КонецЦикла;
    
    	КонецЦикла;
    	
    КонецПроцедуры  // И_ЗаполнитьПоОперациям()
    
    &НаКлиенте
    Процедура ПМЕ_ПерезаполнитьТаблицу(Ответ, ПараметрыВыполнения) Экспорт
    	Если Ответ = КодВозвратаДиалога.Да Тогда
    		Объект.ВыходныеИзделия.Очистить();
    		Объект.МатериалыИРаботы.Очистить();
    		Объект.Трудозатраты.Очистить();
    
    		ЖурналОператора =  ПараметрыВыполнения.ЖурналОператора;
    
    		Диалог = Новый ДиалогРедактированияСтандартногоПериода();
    		Диалог.Период.ДатаНачала = НачалоДня(Объект.Дата);
    		Диалог.Период.ДатаОкончания =КонецДня(Объект.Дата);
    		СтруктураПередачи= Новый Структура;
    		СтруктураПередачи.Вставить("Диалог", Диалог);
    		СтруктураПередачи.Вставить("ЖурналОператора", ЖурналОператора);
    
    		Диалог.Показать(Новый ОписаниеОповещения("УстановитьИнтервалЗавершение", ЭтотОбъект, СтруктураПередачи));
    
    	Иначе
    		Возврат;
    	КонецЕсли;
    		
    КонецПроцедуры
    
    &НаКлиенте
    // Процедура - обработчик команды ЗаполнитьПоФакту.
    // заполняет виды работ, которые были осуществлены сотрудником за выбранный период времени
    Процедура ПМЕ_ЗаполнитьПоЖурналуОператора(Команда)
    	 ПМЕ_ЗаполнитьПоФакту(Истина);
    
     КонецПроцедуры
    &НаКлиенте 
    // Процедура - обработчик команды ЗаполнитьПоФакту.
    // заполняет виды работ, которые были осуществлены сотрудником за выбранный период времени
    Процедура ПМЕ_ЗаполнитьПоФакту(ЖурналОператора)
    	
    	Если Объект.ВыходныеИзделия.Количество() > 0 Тогда
    		Обработчик = Новый ОписаниеОповещения("ПМЕ_ПерезаполнитьТаблицу", ЭтотОбъект,Новый Структура("ЖурналОператора", ЖурналОператора));
    		ПоказатьВопрос(Обработчик, НСтр("ru = 'Перезаполнить таблицы: Продукция, Материалы и работы, Трудозатраты?'"), РежимДиалогаВопрос.ДаНет);
    	Иначе
    	Диалог = Новый ДиалогРедактированияСтандартногоПериода();
    		Диалог.Период.ДатаНачала = НачалоДня(ТекущаяДата());
    		Диалог.Период.ДатаОкончания =КонецДня(ТекущаяДата());
    		СтруктураПередачи= Новый Структура;
    		СтруктураПередачи.Вставить("Диалог", Диалог);
    		СтруктураПередачи.Вставить("ЖурналОператора", ЖурналОператора);
    
    		Диалог.Показать(Новый ОписаниеОповещения("УстановитьИнтервалЗавершение", ЭтотОбъект, СтруктураПередачи));
    КонецЕсли;
    	
    КонецПроцедуры
    &НаКлиенте
    Процедура ТаблицаНоменклатураПриИзмененииПриИзмененииПроизводствоБезЗаказа(ИмяТЧ,ТекущаяСтрока,ИмяСклад)
    	
    	 СтруктураДействий = Новый Структура;
    
    	ДобавитьВСтруктуруДействияПриИзмененииНоменклатуры(ИмяТЧ, ТекущаяСтрока, ЭтаФорма, СтруктураДействий);
    	ДобавитьВСтруктуруДействияПриИзмененииКоличестваУпаковок(ИмяТЧ, ЭтаФорма, СтруктураДействий);
    	
    
    	ДобавитьВСтруктуруДействияПоСериям(СтруктураДействий, ТекущаяСтрока[ИмяСклад],  ЭтаФорма.ПараметрыУказанияСерий[ИмяТЧ]);
    	
    	ОбработкаТабличнойЧастиКлиент.ОбработатьСтрокуТЧ(ТекущаяСтрока, СтруктураДействий, КэшированныеЗначения);
    	
    	Если ИмяТЧ = "ВыходныеИзделия" Тогда
    		ТекущаяСтрока.НаправлениеВыпуска = ПредопределенноеЗначение("Перечисление.ХозяйственныеОперации.ВыпускПродукцииНаСклад");
    	КонецЕсли;
    	
    	 
    КонецПроцедуры
    &НаКлиенте
    Процедура УстановитьИнтервалЗавершение(Результат, ДополнительныеПараметры) Экспорт
    	 	Диалог = ДополнительныеПараметры.Диалог;
    	    ЖурналОператора =  ДополнительныеПараметры.ЖурналОператора;
    
    	Если ЗначениеЗаполнено(Результат) Тогда
    		ПМЕ_ЗаполнитьПоОперациям(Диалог.Период.ДатаНачала, Диалог.Период.ДатаОкончания,ЖурналОператора);
    		Элементы.ВидЦены.Видимость					= Истина;
    		Элементы.ГруппаПобочныеИзделия.Видимость	= Истина;
    		Элементы.ГруппаМатериалыИРаботы.Видимость	= Истина;
    		Элементы.ГруппаТрудозатраты.Видимость		= Истина;
    		Для Каждого Стр Из Объект.ВыходныеИзделия цикл
    			НС =  СписокГрупп.Добавить();
    			ЗаполнитьЗначенияСвойств(НС, Стр);
    			НС.ГруппаЗатрат=Строка(Стр.Номенклатура)+?(ЗначениеЗаполнено(Стр.Характеристика), " / "+Строка(Стр.Характеристика),"");
    		КонецЦикла;
    		УстановитьЗаголовкиГруппПродукции(ЭтаФорма, "ВыходныеИзделия");
    
    
    		попытка
    			Если  Объект.ВыходныеИзделия.Количество()>0 тогда
    				Для каждого Стр из Объект.ВыходныеИзделия Цикл
    					Стр.ГруппаЗатрат=Строка(Стр.Номенклатура)+?(ЗначениеЗаполнено(Стр.Характеристика), " / "+Строка(Стр.Характеристика),"");
    					
    					Для Каждого ТекСтрока Из Объект.МатериалыИРаботы Цикл
    						Если ТекСтрока.НомерГруппыЗатрат =Стр.НомерГруппыЗатрат тогда
    							ТекСтрока.ГруппаЗатрат =Стр.ГруппаЗатрат;
    						КонецЕсли;
    						
    					КонецЦикла;
    					
    					
    					Для Каждого ТекСтрока Из Объект.Трудозатраты Цикл
    							Если ТекСтрока.НомерГруппыЗатрат =Стр.НомерГруппыЗатрат тогда
    								ТекСтрока.ГруппаЗатрат =Стр.ГруппаЗатрат;
    							КонецЕсли;
    					КонецЦикла;
    
    					ТаблицаНоменклатураПриИзмененииПриИзмененииПроизводствоБезЗаказа("ВыходныеИзделия",Стр,"Получатель");
    					
    				КонецЦикла;
    			КонецЕсли;
    			
    		исключение
    		КонецПопытки; 
    		попытка
    			Если  Объект.МатериалыИРаботы.Количество()>0 тогда
    				Для каждого Стр из Объект.МатериалыИРаботы Цикл
    					ТаблицаНоменклатураПриИзмененииПриИзмененииПроизводствоБезЗаказа("МатериалыИРаботы",Стр,"Склад");
    					
    				КонецЦикла;
    			КонецЕсли;
    			
    		исключение
    		КонецПопытки; 
    
    	КонецЕсли;
    	
    КонецПроцедуры // УстановитьИнтервал()
    &НаКлиенте
    Процедура ПМЕ_ЗаполнитьПоОтражениюФактаПланирования(Команда)
    	 ПМЕ_ЗаполнитьПоФакту(ложь);
    
    КонецПроцедуры
    
    #КонецОбласти 
    

36. Заходим в свойства планы видов характеристик «Дополнительные реквизиты и сведения»:

  • дополнительно отмечаем типы «ПМЕ_Плотность», «ПМЕ_Формат», «ПМЕ_Красочность»;
  • в предопределенные данные добавляем реквизит «ШиринаРоля» тип ЧИСЛО(10,2).

37. Установка модуля завершена. Для проверки правильности установленного модуля необходимо выгрузить полученную конфигурацию в файл и сравнить ее с исходной «Полиграфия ERP».

Инструкция по обновлению конфигурации 1C:Оперативная печать 8

Для обновления версии конфигурации следует использовать режим «Обновление конфигураций». Файл обновлений 1Cv8.cfu находится в подкаталоге Armex\...\ соответствующего каталога шаблонов. (Как скачать обновление и установить в каталог шаблонов?)

Сделайте резервную копию вашей информационной базы.

1. Во время обновления конфигурации не должны выполняться регламентные и фоновые задания:

  • Для контроля за выполнением заданий и их отмены необходимо использовать обработку "Консоль заданий" с диска ИТС.
  • Если существуют задания, выполняемые по расписанию, необходимо запретить их выполнение на время обновления конфигурации.

 

 

  • При использовании файлового варианта работы с информационной базой для этого нужно завершить работу программы - планировщика заданий.
  • В клиент-серверном варианте работы следует использовать утилиту администрирования, где нужно установить флаг "Блокировка регламентных заданий включена" в свойствах информационной базы.
  • Если в конфигурации выполнялись доработки, вызывающие запуск фоновых заданий, следует запретить их выполнение на время обновления конфигурации.
  • После обновления конфигурации выполнение заданий можно вновь разрешить.

2. Запустите систему 1С:Предприятие в режиме "Конфигуратор".

3. Откройте конфигурацию, для этого в меню "Конфигурация" выберите пункт "Открыть конфигурацию".

4. Вызовите режим "Обновление конфигураций", для этого в меню "Конфигурация", подменю "Поддержка", выберите пункт "Обновить конфигурацию".

 

 

 

5. В диалоге выбора обновления в качестве источника обновления укажите "Поиск доступных обновлений", после чего выберите нужное обновление в соответствующем списке.

 

6. Если в списке обновлений необходимое обновление отсутствует, то в диалоге выбора обновления в качестве источника обновления укажите "Выбор файла обновления", после чего выберите нужный файл обновления (по умолчанию 1cv8.cfu).

7. В окне "Обновление конфигураций" нажмите кнопку "Готово" для продолжения обновления конфигурации.

 

8. После завершения будет открыто окно "Конфигурация", содержащее конфигурацию с внесенными изменениями. Выполните сохранение конфигурации.

9. Текущая версия конфигурации предназначена для использования с обновленной версией системы лицензирования и защиты конфигурации 3.0.. Обновленные файлы защиты расположены в подкаталоге Protection (В подкаталоге tmplts\Armex\...\ соответствующего каталога шаблонов).

 

 

В подкаталог Protection включены следующие установочные пакеты:

LicenceServer-{version}.Win.exe

  • Установочный пакет сервера СЛК и необходимых для его работы компонент(программа настройки параметров, программа управления службой).

LicenceAddIn-{version}.Debug.Win.exe

  • Установочный пакет внешней компоненты
    для установки/обновления компоненты без изменения макетов конфигураций.

UPKey-X.X.X.X-X.exe

  •  Программа установки драйвера аппаратного ключа защиты.

Activation-3.0.pdf

  • Описание установки системы лицензирования и защиты конфигурации.

LicenceServer-{version}.zip

  • Общий установочный пакеты сервера и драйвер ключа защиты для всех поддерживаемых ОС.

LicenceAddIn-{version}.zip

  • Общий установочный пакет компоненты для всех поддерживаемых ОС.
    7758.zip
  • архив с защищенными объектами конфигурации и лицензионными параметрами

Установка всех компонент производится в папку:
%ProgramFiles%>\1C\Licence\3.0

Инструкция по обновлению конфигурации 1С:Фотоуслуги 8

Для обновления конфигурации следует использовать режим "Обновление конфигураций". Файл обновлений 1Cv8.cfu находится в каталоге шаблонов Armex\...... каталога шаблонов. (Как скачать обновление и установить в каталог шаблонов?)

1. Сделайте резервную копию вашей информационной базы.

2. Запустите 1С:Предприятие в режиме "Конфигуратор".

3. Откройте конфигурацию, для этого в меню "Конфигурация" выберите пункт "Открыть конфигурацию".

 

4. Вызовите режим "Обновление конфигураций", для этого в меню "Конфигурация", подменю "Поддержка", выберите пункт "Обновить конфигурацию".

 

5. В диалоге выбора обновления в качестве источника обновления укажите "Доступные обновления", после чего выберите нужное обновление в соответствующем списке.

 

 

 

6. Если в списке обновлений необходимое обновление отсутствует, то в диалоге выбора обновления в качестве источника обновления укажите "Файл обновления", после чего выберите нужный файл обновления (по умолчанию 1cv8.cfu).

7. В окне "Обновление конфигураций" нажмите кнопку "OK" для продолжения обновления конфигурации.

 

 

8. После завершения будет открыто окно "Конфигурация", содержащее конфигурацию с внесенными изменениями. Выполните сохранение конфигурации.

 

 

9. Запустите 1С:Предприятие в режиме "1С:Предприятие".

 

 

10. Текущая версия конфигурации предназначена для использования с обновленной версией системы лицензирования и защиты конфигурации 3.0………. Обновленные файлы защиты расположены в подкаталоге Protection (В подкаталоге ..\\Armex\ ….. каталога шаблонов)

 

В подкаталог Protection включены следующие установочные пакеты:

LicenceServer-{version}.Win.exe

  • Установочный пакет сервера СЛК и необходимых для его работы компонент
    (программа настройки параметров, программа управления службой).

  

LicenceAddIn-{version}-Win.exe

  • Установочный пакет внешней компоненты
    для установки/обновления компоненты без изменения макетов конфигураций.

UPKey-X.X.X.X-X.exe

  • Программа установки драйвера аппаратного ключа защиты.
    25B3.zip
  • архив с защищенными объектами конфигурации и лицензионными параметрами

Установка всех компонент производится в папку:

%ProgramFiles%>\1C\Licence\3.0

Инструкция по обновлению конфигурации 1С:Издательство 8

Для обновления конфигурации следует использовать режим "Обновление конфигураций". Файл обновлений 1Cv8.cfu находится в каталоге шаблонов Armex\...... каталога шаблонов. (Как скачать обновление и установить в каталог шаблонов?)

1. Сделайте резервную копию вашей информационной базы.

2. Запустите 1С:Предприятие в режиме "Конфигуратор".

3. Откройте конфигурацию, для этого в меню "Конфигурация" выберите пункт "Открыть конфигурацию".

 

4. Вызовите режим "Обновление конфигураций", для этого в меню "Конфигурация", подменю "Поддержка", выберите пункт "Обновить конфигурацию".

 

5. В диалоге выбора обновления в качестве источника обновления укажите "Доступные обновления", после чего выберите нужное обновление в соответствующем списке.

 

 

 

6. Если в списке обновлений необходимое обновление отсутствует, то в диалоге выбора обновления в качестве источника обновления укажите "Файл обновления", после чего выберите нужный файл обновления (по умолчанию 1cv8.cfu).

7. В окне "Обновление конфигураций" нажмите кнопку "OK" для продолжения обновления конфигурации.

 

 

8. После завершения будет открыто окно "Конфигурация", содержащее конфигурацию с внесенными изменениями. Выполните сохранение конфигурации.

 

 

9. Запустите 1С:Предприятие в режиме "1С:Предприятие".

 

 

10. Текущая версия конфигурации предназначена для использования с обновленной версией системы лицензирования и защиты конфигурации 3.0………. Обновленные файлы защиты расположены в подкаталоге Protection (В подкаталоге ..\\Armex\ ….. каталога шаблонов)

 

В подкаталог Protection включены следующие установочные пакеты:

LicenceServer-{version}.Win.exe

  • Установочный пакет сервера СЛК и необходимых для его работы компонент
    (программа настройки параметров, программа управления службой).

  

LicenceAddIn-{version}-Win.exe

  • Установочный пакет внешней компоненты
    для установки/обновления компоненты без изменения макетов конфигураций.

UPKey-X.X.X.X-X.exe

  • Программа установки драйвера аппаратного ключа защиты.
    25B3.zip
  • архив с защищенными объектами конфигурации и лицензионными параметрами

Установка всех компонент производится в папку:

%ProgramFiles%>\1C\Licence\3.0

Инструкция по обновлению конфигурации 1С:Полиграфия 8

Для обновления версии конфигурации следует использовать режим «Обновление конфигураций». Файл обновлений 1Cv8.cfu находится в подкаталоге Armex\...\ соответствующего каталога шаблонов. (Как скачать обновление и установить в каталог шаблонов?)

Сделайте резервную копию вашей информационной базы.

1. Во время обновления конфигурации не должны выполняться регламентные и фоновые задания:

  • Для контроля за выполнением заданий и их отмены необходимо использовать обработку "Консоль заданий" с диска ИТС.
  • Если существуют задания, выполняемые по расписанию, необходимо запретить их выполнение на время обновления конфигурации.

 

 

  • При использовании файлового варианта работы с информационной базой для этого нужно завершить работу программы - планировщика заданий.
  • В клиент-серверном варианте работы следует использовать утилиту администрирования, где нужно установить флаг "Блокировка регламентных заданий включена" в свойствах информационной базы.
  • Если в конфигурации выполнялись доработки, вызывающие запуск фоновых заданий, следует запретить их выполнение на время обновления конфигурации.
  • После обновления конфигурации выполнение заданий можно вновь разрешить.

2. Запустите систему 1С:Предприятие в режиме "Конфигуратор".

3. Откройте конфигурацию, для этого в меню "Конфигурация" выберите пункт "Открыть конфигурацию".

4. Вызовите режим "Обновление конфигураций", для этого в меню "Конфигурация", подменю "Поддержка", выберите пункт "Обновить конфигурацию".

 

 

 

5. В диалоге выбора обновления в качестве источника обновления укажите "Поиск доступных обновлений", после чего выберите нужное обновление в соответствующем списке.

 

6. Если в списке обновлений необходимое обновление отсутствует, то в диалоге выбора обновления в качестве источника обновления укажите "Выбор файла обновления", после чего выберите нужный файл обновления (по умолчанию 1cv8.cfu).

7. В окне "Обновление конфигураций" нажмите кнопку "Готово" для продолжения обновления конфигурации.

 

8. После завершения будет открыто окно "Конфигурация", содержащее конфигурацию с внесенными изменениями. Выполните сохранение конфигурации.

9. Текущая версия конфигурации предназначена для использования с обновленной версией системы лицензирования и защиты конфигурации 3.0.. Обновленные файлы защиты расположены в подкаталоге Protection (В подкаталоге tmplts\Armex\...\ соответствующего каталога шаблонов).

 

 

В подкаталог Protection включены следующие установочные пакеты:

LicenceServer-{version}.Win.exe

  • Установочный пакет сервера СЛК и необходимых для его работы компонент(программа настройки параметров, программа управления службой).

LicenceAddIn-{version}.Debug.Win.exe

  • Установочный пакет внешней компоненты
    для установки/обновления компоненты без изменения макетов конфигураций.

UPKey-X.X.X.X-X.exe

  •  Программа установки драйвера аппаратного ключа защиты.

Activation-3.0.pdf

  • Описание установки системы лицензирования и защиты конфигурации.

LicenceServer-{version}.zip

  • Общий установочный пакеты сервера и драйвер ключа защиты для всех поддерживаемых ОС.

LicenceAddIn-{version}.zip

  • Общий установочный пакет компоненты для всех поддерживаемых ОС.
    7758.zip
  • архив с защищенными объектами конфигурации и лицензионными параметрами

Установка всех компонент производится в папку:
%ProgramFiles%>\1C\Licence\3.0

Инструкция по обновлению конфигурации 1C:Широкоформатная печать 8

Для обновления версии конфигурации следует использовать режим «Обновление конфигураций». Файл обновлений 1Cv8.cfu находится в подкаталоге Armex\...\ соответствующего каталога шаблонов. (Как скачать обновление и установить в каталог шаблонов?)

Сделайте резервную копию вашей информационной базы.

1. Во время обновления конфигурации не должны выполняться регламентные и фоновые задания:

  • Для контроля за выполнением заданий и их отмены необходимо использовать обработку "Консоль заданий" с диска ИТС.
  • Если существуют задания, выполняемые по расписанию, необходимо запретить их выполнение на время обновления конфигурации.

 

 

  • При использовании файлового варианта работы с информационной базой для этого нужно завершить работу программы - планировщика заданий.
  • В клиент-серверном варианте работы следует использовать утилиту администрирования, где нужно установить флаг "Блокировка регламентных заданий включена" в свойствах информационной базы.
  • Если в конфигурации выполнялись доработки, вызывающие запуск фоновых заданий, следует запретить их выполнение на время обновления конфигурации.
  • После обновления конфигурации выполнение заданий можно вновь разрешить.

2. Запустите систему 1С:Предприятие в режиме "Конфигуратор".

3. Откройте конфигурацию, для этого в меню "Конфигурация" выберите пункт "Открыть конфигурацию".

4. Вызовите режим "Обновление конфигураций", для этого в меню "Конфигурация", подменю "Поддержка", выберите пункт "Обновить конфигурацию".

 

 

 

5. В диалоге выбора обновления в качестве источника обновления укажите "Поиск доступных обновлений", после чего выберите нужное обновление в соответствующем списке.

 

6. Если в списке обновлений необходимое обновление отсутствует, то в диалоге выбора обновления в качестве источника обновления укажите "Выбор файла обновления", после чего выберите нужный файл обновления (по умолчанию 1cv8.cfu).

7. В окне "Обновление конфигураций" нажмите кнопку "Готово" для продолжения обновления конфигурации.

 

8. После завершения будет открыто окно "Конфигурация", содержащее конфигурацию с внесенными изменениями. Выполните сохранение конфигурации.

9. Текущая версия конфигурации предназначена для использования с обновленной версией системы лицензирования и защиты конфигурации 3.0.. Обновленные файлы защиты расположены в подкаталоге Protection (В подкаталоге tmplts\Armex\...\ соответствующего каталога шаблонов).

 

 

В подкаталог Protection включены следующие установочные пакеты:

LicenceServer-{version}.Win.exe

  • Установочный пакет сервера СЛК и необходимых для его работы компонент(программа настройки параметров, программа управления службой).

LicenceAddIn-{version}.Debug.Win.exe

  • Установочный пакет внешней компоненты
    для установки/обновления компоненты без изменения макетов конфигураций.

UPKey-X.X.X.X-X.exe

  •  Программа установки драйвера аппаратного ключа защиты.

Activation-3.0.pdf

  • Описание установки системы лицензирования и защиты конфигурации.

LicenceServer-{version}.zip

  • Общий установочный пакеты сервера и драйвер ключа защиты для всех поддерживаемых ОС.

LicenceAddIn-{version}.zip

  • Общий установочный пакет компоненты для всех поддерживаемых ОС.
    7758.zip
  • архив с защищенными объектами конфигурации и лицензионными параметрами

Установка всех компонент производится в папку:
%ProgramFiles%>\1C\Licence\3.0

Как скачать обновление и установить шаблон обновления?

Сначала скачиваем обновление с портала ИТС https://portal.1c.ru/ .  Для доступа необходимо ввести свои регистрационные данные.

 

 

 

 

Распаковываем полученный архив.

 

 

Запускаем установщик.

 

 

 

Выбираем /создаем каталог для шаблонов обновлений.

 

 

 

Файл обновления конфигурации имеет расширение .cfu

 

 

Копируем путь к этому каталогу  обновления

 

 

Запускаем программу, переходим в окно настройки и добавляем наш путь к каталогу обновления.

 

 

Программа будет при обновлении обращаться именно к этому каталогу.

Система лицензирования наших решений (СЛК)

Все наши решения защищены Системой Лицензирования Конфигураций (СЛК) от разработчика «Катран».

По ссылке можно найти актуальные дистрибутивы и инструкции по установке

Инструкция по обновлению нетиповой конфигурации

Прежде чем приступить к обновлению, настоятельно рекомендуется сделать резервную копию информационной базы!!!

1. На сайте https://releases.1c.ru скачиваем и устанавливаем обновление, которое хотим установить (не забываем, что есть обязательные обновления, которые нельзя «перескакивать» и «не обязательные») на свою конфигурацию.

2. Запускаем систему 1С: Предприятие в режиме "Конфигуратор" (у учетной записи, под которой запускаем систему, обязательно должны быть права администратора).

3. Выбираем пункт меню «Обновить конфигурацию» согласно скриншоту ниже (если вдруг данный пункт не активен, то сначала необходимо выбрать пункт «Открыть конфигурацию»):

 

4. В появившемся окне выбираем один из предложенных способов указания «Источника обновления».

Пункты с 1 по 4 абсолютно такие же, как и в случае обновления типовой конфигурации, поэтому подробно не описываются.

5. После указания «Источника обновления»:

 

система начнет сравнение конфигураций, это займет некоторое время (зависит от мощности машины). Когда этап сравнения будет завершен, появится следующее окно:

 

С данного этапа начинается непосредственно обновление, все действия необходимо выполнять очень внимательно, потому как любая ошибка может привести к потере данных!!!

6. Снимаем галочку «Сохранять настройки автоматически» в нижней части окошка. При этом Фильтр (там же, внизу) должен быть установлен на «Показывать отличия основной и новой конфигурации поставщика от старой конфигурации поставщика» (данный фильтр устанавливается автоматически, нужно лишь убедиться в том, что Вы случайно НЕ выбрали другой):

 

7. Переходим в основную часть окна. Разворачиваем через «плюсик» дерево обработок (без разницы с какой стороны нажимать «плюсик», можно справа, можно слева), среди них находим обработку «П_ОперативныйЖурналОператора» и у нее находим форму «ФормаДляTouchScreen» - полностью разворачиваем, должно получится так:

 

Щелкаем на зубчатом колесике напротив надписи «Форма»:

 

Откроется вот такое окно:

 

В нем наверху проставляем галочки напротив названий процедур/функций в колонке «Основная конфигурация». Убеждаемся, что справа присутствуют только надписи «Взять из новой конфигурации поставщика» или «Удалить» (если данная строка подсвечена оранжевым цветом, при этом в колонке «Основная конфигурация» присутствует наименование процедуры/функции, а в колонке «Новая конфигурация поставщика» написано «»). Если это не так, из выпадающего меню в колонке «Режим объединения» выбираем соответствующую надпись (действие):

 

В нем наверху проставляем галочки напротив названий процедур/функций в колонке «Основная конфигурация». Убеждаемся, что справа присутствуют только надписи «Взять из новой конфигурации поставщика» или «Удалить» (если данная строка подсвечена оранжевым цветом, при этом в колонке «Основная конфигурация» присутствует наименование процедуры/функции, а в колонке «Новая конфигурация поставщика» написано «»). Если это не так, из выпадающего меню в колонке «Режим объединения» выбираем соответствующую надпись (действие):

 

После чего нажимаем кнопку «ОК» внизу, вас «вернет» на предыдущее окно, но на фоне зубчатого колесика появится зеленая галочка:

 

8. Далее проделываем те же действия, что описаны в пп 7 для формы «ФормаДляTouchScreen» обработки «П_ОтражениеФактаПланированияПолиграфии»:

 

 

 

9. Переходим к справочнику «П_РолиПользователей». Убеждаемся, что снята галочка напротив реквизита «ВариантаЗакрытияТачСкрина», а также проверяем, есть ли значок карандаша напротив формы «ФормаЭлемента» в правой колонке, и если такого значка нет (как на скриншоте ниже), то снимаем галочку также с формы «ФормаЭлемента»:

 

Если значок карандаша есть, то галочки надо проставить, если не стоят и убедиться, что в колонке "Режим объединения и порядок подчиненных объектов" появилась надпись «Взять из новой конфигурации поставщика», если там другая надпись – выбрать именно надпись «Взять из новой конфигурации поставщика».

10. Далее, ничего более не трогая, нажимаем на кнопку «Выполнить» внизу справа и дожидаемся пока выполнится обновление. Если вдруг появится такое окно:

 

то нажимаем «Да», если появится такое окно:

 

то нажимаем «ОК» ничего не меняя. В итоге должно появиться такое окно (нажать в нем «ОК»):

 

11. Если в пп. 9 у Вас был значок карандаша напротив формы «ФормаЭлемента» в правой колонке, то необходимо выполнить следующие действия (если значка карандаша не было, этот пункт пропускаем!!!).

В окне конфигурации находим справочник «П_РолиПользователей»:

 

Если у Вас такого окна нет, то вызвать его можно через меню:

 

Открываем у этого справочника форму «ФормаЭлемента» двойным щелчком по ней, форма откроется, в ней аккуратно переходим к вкладке «Изменение реквизитов» и далее к вкладке «Планирование»:

 

мышкой выделяем нижние обе рамки со всеми объектами в них:

 

после чего аккуратно сдвигаем их чуть выше, чтобы получилось вот так (освободилось место снизу):

 

Теперь копируем одну из рамок (любую) с двумя (любыми) «радиокнопками» и смещаем ниже (при необходимости изменяем размеры скопированной рамки, чтобы не мешала другим):

 

У новой рамки меняем заголовок на «Вариант закрытия формы Touch Screen» (для этого нужно двойным щелчком нажать на объект, в котором хотите что-либо изменить, справа появится «Окно свойств» и в нем уже меняем необходимое свойство). У скопированного объекта «Основная форма»:

 

изменяем свойства: имя на «ВариантаЗакрытияТачСкрина», заголовка на «Кнопка "Закрыть форму"», данные на «ВариантаЗакрытияТачСкрина», подсказку на «Кнопка "Закрыть форму"», выбираемое значение на «0»:

 

Дальше аналогично изменяем свойства у скопированного объекта «Форма для Touch Screen»:

 

изменяем: имя на «Переключатель5» (или любую другую цифру, если 5 не даст установить), заголовка на «При запуске в работу / выполнении операции», данных тут нет (для этого должна быть снята галочка «Первый в группе», подсказку затираем (если она есть), выбираемое значение на «1»:

 

Немного растягиваем получившиеся объекты (чтобы влезли надписи), должно получится примерно так:

 

12. Находим точно также, как и в пп. 11 обработку «П_ОперативныйЖурналОператора» и у нее открываем форму «ФормаДляTouchScreen» двойным щелчком. Находясь в окне формы переходим в окно модуля:

 

Там вы увидите функции и процедуры формы. Листаем в самый низ и добавляем следующие 2 процедуры (скопировать и вставить выделенный цветом текст):

// +++ Армекс доработки от 29.09.2017
Функция ПроверкаЗакрытияФормы()
	ФормуЗакрыть=Ложь;
	Запрос = Новый Запрос;
	Запрос.Текст = "ВЫБРАТЬ
	|	ЕСТЬNULL(П_РолиПользователей.ВариантаЗакрытияТачСкрина, 0) КАК ВариантаЗакрытияТачСкрина
	|ИЗ
	|	Справочник.Пользователи КАК Пользователи
	|		ЛЕВОЕ СОЕДИНЕНИЕ Справочник.П_РолиПользователей КАК П_РолиПользователей
	|		ПО Пользователи.П_РольПользователя = П_РолиПользователей.Ссылка
	|ГДЕ
	|	Пользователи.Ссылка = &Пользователь";
	
	Запрос.УстановитьПараметр("Пользователь",глЗначениеПеременной("глТекущийПользователь"));
	ВыборкаПрав = Запрос.Выполнить().Выгрузить();
	
	Если ВыборкаПрав.Количество() > 0 Тогда
		Если   ВыборкаПрав[0].ВариантаЗакрытияТачСкрина =1 тогда
			ФормуЗакрыть=истина;
			
		КонецЕсли;
	КонецЕсли;	
	Возврат  ФормуЗакрыть;
Конецфункции

Процедура ПриЗакрытии()
	Если ПроверкаЗакрытияФормы() тогда
		Попытка
			Если ВладелецФормы= Неопределено тогда		   
				// передадим управление на форму идентификации сотрудника	
				ФормаДокумента = ПолучитьФорму("ФормаИдентификацииСотрудника");
				ФормаДокумента.Открыть();
				
			КонецЕсли;
		Исключение
		КонецПопытки;
	КонецЕсли;
КонецПроцедуры
// --- Армекс доработки от 29.09.2017

Далее находим процедуру "ЗавершитьНажатие" и вставляем в самый конец этой процедуры текст:

// +++ Армекс доработки от 29.09.2017
	
	Если ПроверкаЗакрытияФормы() тогда
		Закрыть();
	КонецЕсли;
	// --- Армекс доработки от 29.09.2017

В процедуру "НачатьНажатие" вставляем также в самый конец:

// +++ Армекс доработки от 29.09.2017
			
			Если ПроверкаЗакрытияФормы() тогда
				Закрыть();
			КонецЕсли;
			// --- Армекс доработки от 29.09.2017

После этого возвращаемся в окно «Диалог» этой формы и выбираем в качестве события этой формы добавленную процедуру «ПриЗакрытии»:

 

13. Аналогично пп. 12 вставляем в модуль формы «ФормаДляTouchScreen» обработки «П_ОтражениеФактаПланированияПолиграфии» следующее. Листаем в самый низ и добавляем следующие 2 процедуры (скопировать и вставить выделенный цветом текст):

Процедура ПриЗакрытии()
		Если ПроверкаЗакрытияФормы() тогда
		
		Попытка
			Если ВладелецФормы= Неопределено тогда		   
				// передадим управление на форму идентификации сотрудника	
				ФормаДокумента = ПолучитьФорму("ФормаИдентификацииСотрудника");
				ФормаДокумента.Открыть();
				
			КонецЕсли;
		Исключение
		КонецПопытки;
		
		
	КонецЕсли;

КонецПроцедуры

Функция ПроверкаЗакрытияФормы()
	
	ФормуНужноЗакрыть=Ложь;
	Запрос = Новый Запрос;
	Запрос.Текст = "ВЫБРАТЬ
	|	ЕСТЬNULL(П_РолиПользователей.ВариантаЗакрытияТачСкрина, 0) КАК ВариантаЗакрытияТачСкрина
	|ИЗ
	|	Справочник.Пользователи КАК Пользователи
	|		ЛЕВОЕ СОЕДИНЕНИЕ Справочник.П_РолиПользователей КАК П_РолиПользователей
	|		ПО Пользователи.П_РольПользователя = П_РолиПользователей.Ссылка
	|ГДЕ
	|	Пользователи.Ссылка = &Пользователь";
	
	Запрос.УстановитьПараметр("Пользователь",глЗначениеПеременной("глТекущийПользователь"));
	ВыборкаПрав = Запрос.Выполнить().Выгрузить();
	
	Если ВыборкаПрав.Количество() > 0 Тогда
		Если   ВыборкаПрав[0].ВариантаЗакрытияТачСкрина =1 тогда
			ФормуНужноЗакрыть=истина;
			
		КонецЕсли;
	КонецЕсли;	
	Возврат  ФормуНужноЗакрыть;
Конецфункции

Далее находим процедуру "ЗавершитьНажатие" и вставляем в самый конец этой процедуры текст:

Если ПроверкаЗакрытияФормы() тогда
				Закрыть();

			КонецЕсли;

В процедуру "НачатьНажатие" вставляем также в самый конец:

Если ПроверкаЗакрытияФормы() тогда
		Закрыть();
	КонецЕсли;

После этого возвращаемся в окно «Диалог» этой формы и выбираем в качестве события этой формы добавленную процедуру «ПриЗакрытии»:

 

14. Осталось только обновить конфигурацию, для этого необходимо выбрать следующий пункт меню:

 

и подтвердить изменения:

 

Важно!!! В этом окошке не должно быть никаких восклицательных знаков или других значков, кроме синих стрелочек слева, как на скриншоте выше. Если они присутствуют, то прежде, чем соглашаться, нужно понять почему они появились, и с чем Вы соглашаетесь!!!

15. Последнее что нужно сделать – запустить 1с в режиме Предприятия не выходя из конфигуратора. Для этого необходимо выбрать следующий пункт меню:

 

1с запустится и будут выполнены необходимые строки кода. Вам нужно будет лишь подождать, ничего не нажимая. Когда 1с окончательно обновится появится окно с изменениями в новом релизе.

Инструкция по передаче конфигурационного файла 1C (CF) или копии информационной БД

Для сохранения конфигурации

Для сохранения конфигурации в файл - нужно запустить 1С:Предприятие в режиме «Конфигуратор»

 

Далее перейти по закладке Конфигурация – Сохранить конфигурацию в файл.

 

Можете заранее определить каталог куда будите сохранять или выбрать существующий, по своему усмотрению.

 

Нажимаем на кнопку сохранить. Таким образом вы выгрузили вашу конфигурацию в файл.

 

Для сохранения информационной базы

Если нужно сохранить информационную базу, то последовательность следующая – запускаем 1С Предприятие в режиме Конфигуратора. Меню Администрирование- Выгрузить информационную базу

 

Также можно заранее создать каталог для этих целей или сохранить или выбрать существующий, по своему усмотрению.

 

Это сохранение информационной базы относится к файловым вариантам информационных баз и небольших до 10 гб баз реализованных в клиент-серверном варианте.

В клиент-серверном варианте для сохранение информационной базы следует использовать средства СУБД.


Передача файла через облачный файлообменник

Эти файлы можете предоставить разработчикам – программистам для тестирования и исправления каких-либо ошибок или доработок . Если почтовый клиент не пропускает большой объем (размер файла), то можете использовать файловые обменники: Files, Яндекс диск, Google disk, Облако Mail.Ru, высылая ссылку на скачивание.

Ссылки на файловые обменники:

Как сохранить из базы данных 1С конфигурационный файл (CF – 1CV8.cf)?

Система позволяет сохранять конфигурацию прикладного решения в виде файла и загружать конфигурацию из файла, полностью заменяя существующую конфигурацию.

Запускаем программу в режиме «Конфигуратор»

 

Сохранение конфигурации

Сохранение конфигурации прикладного решения в файл на диске может быть использовано для создания новой конфигурации прикладного решения, основу которой составляет текущая конфигурация, или для последующего сравнения и объединения с другими конфигурациями. Конфигурация сохраняется в файл с расширением *.cf.

 


Передача файла через облачный файлообменник

Эти файлы можете предоставить разработчикам – программистам для тестирования и исправления каких-либо ошибок или доработок . Если почтовый клиент не пропускает большой объем (размер файла), то можете использовать файловые обменники: Files, Яндекс диск, Google disk, Облако Mail.Ru, высылая ссылку на скачивание.

Ссылки на файловые обменники:

Как загрузить в базу данных 1С конфигурационный файл (CF – 1CV8.cf)?

Система позволяет сохранять конфигурацию прикладного решения в виде файла и загружать конфигурацию из файла, полностью заменяя существующую конфигурацию.

Запускаем программу в режиме «Конфигуратор»

 

Загрузка конфигурации

Загрузка конфигурации из файла позволяет полностью заменить текущую конфигурацию прикладного решения на конфигурацию, сохраненную в файле. Этот режим может использоваться в случае, когда текущая конфигурацию должна быть полностью заменена на другую конфигурацию или при создании новой конфигурации прикладного решения, основу которой составляет загружаемая конфигурация.

 

Настройки Microsoft SQL Server для работы с 1С:Предприятием

Настройки Microsoft SQL Server для работы с 1С:Предприятием

  • Проверить работу «Database instant file initialization».
  • Схема управления питанием – «Высокая производительность»
  • Проверить отсутствие сжатия файлов данных и файлов журналов.
  • Включить аутентификацию SQL Server.
  • Настроить резервное копирование
  • Добавить файлы данных и журнала транзакций в исключения системы автоматического резервного копирования
  • Настройки сервера (ServerProperties)
  • Использование памяти.   
  • Включить возможность административного подключения
  • Параметры базы данных   
  • Флаги трассировки
  • Настройка сетевых протоколов
  • Обслуживание баз
  • Настроить операторов для оповещения об ошибках

Подробнее

 

Создание планов обслуживания.

  • Настройка автоматического обновления статистик
  • Очистка процедурного КЭШа
  • Настройка очистки процедурного КЭШа
  • Дефрагментация индексов
  • Настройка дефрагментации индексов
  • Реиндексация таблиц базы данных
  • Настройка реиндексации таблиц

Подробнее

Настройка резервного копирования базы данных 1С в облачные сервисы Yandex, Mail.Ru, Google и другие

Настройка в 1C

Компания->Еще больше возможностей->Администрирование->Резервное копирование и восстановление

 

Оставляем по умолчанию «На локальном компьютере» и переходим к настройке резервного копирования

 

Настраиваем расписание и глубину архива

 

 

Можно не настраивать расписание и делать резервную копию БД по усмотрению пользователя. Для этого также выбираем вариант на локальном компьютере и указываем каталог, в который будем сохранять.

 

 

 

Таким образом мы создали резервную копию.

Для того чтобы резервная копия сохранялась в облачном архиве, нам нужно установить на вашем компьютере агрегатор облачных сервисов. 

Рассмотрим на примере облачного сервиса Mail.ru.

Заходим в почту на mail.ru, переходим в облако.

Для этого нам нужно выбрать и запустить нужный дистрибутив.

 

 

 

Вы можете выбрать любой вариант с каким облачным сервисом будет взаимодействовать ваш агрегатор. На этом примере выбираем бесплатный (только облако Mail.ru).

После установки у вас на компьютере появится облачный диск.

Создаем в нем каталог , например, «Архив 1с»  

И теперь указываем в настройках программы  этот каталог.

Резервное копирование осуществляется аналогично примеру описанному выше.

 

Только теперь оно будет храниться и в облачном сервисе. И на своем компьютере вы будете иметь прямой доступ к этой резервной копии.

 

Архивация базы данных 1С в облачный сервис «1С:Облачный архив

О сервисе «1С: Облачный архив» по ссылке https://portal.1c.ru/app/arhiv

Как подключить и удалить расширение в конфигурациях 1С:Предприятие?

1. Откройте базу 1С:УНФ 8. Полиграфия 2 и перейдите в раздел «Компания->Администрирование». Зайдите в пункт «Печатные формы, отчеты, обработки».

 

2. Нажмите на пункт «Расширение возможностей программы» (если у Вас нет такого пункта меню, значит это старая конфигурация и она не поддерживает работу с расширениями)

 

3. Нажмите кнопку «Добавить из файла» и выберите файл с расширением (*.cfe), который вы получили. Откройте его:

 

4. Может появиться окно «Предупреждение безопасности» — нажмите «Да»:

Внимание! Рекомендуется обращать внимание на источник, из которого был получен данный файл. Если с источником нет договоренности о разработке дополнительных модулей, или есть сомнения в содержимом файла, то его не рекомендуется открывать, поскольку это может нанести вред компьютеру и данным.

Разрешить открывать данный файл?

 

5. Может появиться окно с информацией, что нужно еще раз повторить действие. Просто вернитесь на пп. 3 и повторите добавление расширения.

 

6. Т.к. для заполнения реквизитов, расширение будет обращаться в интернет, то нужно снять галочку «Безопасный режим» и после этого перезапустить программу 1С.

 

После запуска 1С:Предприятие, расширение должно будет автоматически подключиться и вы можете начать работу с ним.

 

Внимание! Перед обновлением на новую версию, данное расширение нужно ОБЯЗАТЕЛЬНО УДАЛИТЬ!



Удаление расширения перед обновлением на новую версию 1С:УНФ 8. Полиграфия 2

1. В списке расширений нажмите «Удалить»:

 

При этом, предварительно отключать расширение не обязательно. 1С корректно удаляет даже активные расширения.

2. На предупреждение безопасности ответьте «Удалить»:

 

3. Дождитесь завершения удаления расширения:

 

4. Перезапустите 1С:

 

 

Заказать обратный звонок

*
*
* Введите код!

Если вы не можете разобрать цифры на
картинке, нажмите здесь
Поля помеченые *, обязательны для заполнения

Сообщить об ошибке

*
* Введите код!

Если вы не можете разобрать цифры на
картинке, нажмите здесь
Поля помеченые *, обязательны для заполнения

Обратный звонок в техническую поддержку

*
*
* Введите код!

Если вы не можете разобрать цифры на
картинке, нажмите здесь
Поля помеченые *, обязательны для заполнения